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Introduction: Altiris® Deployment Solution™ for Dell Servers 

Remotely manage and automate administration of Dell servers using Altiris® Deployment 
Solution™ for Dell servers software. This add-on to Deployment Solution allows you to remotely 
provision and manage Dell servers by running pre-configured or generated deployment jobs that 
incorporate the Dell OpenManage Deployment Toolkit and Dell Update Packages. From the 
Deployment Console, you can configure Dell servers with a Windows or Linux operating system, 
“rip and replace” server blades, or schedule pre-configured jobs for each phase of server 
provisioning (or for all phases at once). 

From an initial “bare-metal” state, configure servers with BIOS, RAID, BMC, and DRAC settings, 
install an operating system using a scripted install or image, and update hardware configurations 
using Dell Update Packages. Using the tools and pre-configured deployment jobs provided in 
Deployment Solution for Dell servers, you can remotely install servers out-of-the-box and manage 
them across all phases of server provisioning for their entire lifecycle. 

Integrated Dell Tools with Deployment Solution

Deployment Solution for Dell servers consolidates the Dell OpenManage Deployment Toolkit 
(DTK) and Dell Update Packages (DUPs) with management features provided with Deployment 
Solution. Dell server tools can be executed remotely from the Deployment Console to configure 
RAID, DRAC, BMC, and BIOS settings. DUP jobs to apply firmware and driver updates can now 
be deployed to the proper servers at a scheduled time. The easy-to-use, graphical interface of 
Deployment Solution lets you optimize the performance and value of both Altiris and Dell server 
tools. 

Easy-to-use Server Management Console

Deployment Solution is a complete server deployment infrastructure designed to manage Windows 
and Linux servers from an easy-to-use, graphically-based Deployment Console. Deployment 
Solution for Dell servers adds pre-configured deployment jobs displayed in the Deployment Console 
that allows administrators to remotely set up servers.

The deployment jobs installed with Deployment Solution for Dell servers allow administrators to 
pre-assign deployment jobs to new servers that will run automatically when the server starts. And 
with role and scope security features, only authorized staff personnel can have rights to access and 
manage sensitive server deployment tasks. 

Simplified Server Deployment and Configuration
Use Altiris® solutions to simplify administration tasks to deploy new servers, and to diagnose and 
repair non-compliant servers. Administrators can inventory server properties to remotely diagnose 
common problems and enable advanced automation to fix servers on-the-fly. Whether it’s support 
for client-side scripting, post-configuration updates, or conditional error handling, Deployment 
Solution for Dell servers provides complete server deployment and management features.

Either before or after a server is deployed, administrators can also install Dell Update Packages using 
pre-configured jobs for each server model. DUP jobs scheduled from the Deployment Console 
simplify configuration of Dell servers using firmware updates and integrated server-configuration 
tools. And for server blades, you can quickly rip and replace new blades for each rack, enclosure, 
and bay using customized features.
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 Managing Dell Servers from the Deployment Console

You don’t have to leave your desk or notebook to manage Dell servers. From the Deployment 
Console, you can perform common server management tasks by simply dragging a job to a server 
or server group to run jobs as a batch of deployment tasks or one at a time. It’s that flexible and easy. 

Deployment Console Overview
The Deployment Console (a Windows or web user interface) displays all computer resources, 
deployment jobs, and update packages in a single view. From the Deployment Console, each server 
can be identified by a distinct server icon displayed in the Computers pane. You can then assign tasks 
to each server or group of servers by assigning deployment job icons that are displayed and 
organized in the Jobs pane. From a Deployment Console, you can edit scripts, modify deployment 
tasks, and schedule jobs. Additional information for computers and deployment jobs are displayed 
in the right Details pane.

The Deployment Solution for Dell Servers jobs are displayed in the Jobs pane. This folder contains pre-
built jobs that can be edited and used for specific phases of server provisioning. These jobs are 
assigned to selected servers from the Deployment Console, with each job furnishing sequential tasks 
that can be modified to run on selected servers for every phase of server management. These tasks 
include scripts that can be run as installed or edited as needed for your hardware and environment. 

Server deployment jobs are provided for all phases of server deployment, including:

1 Pre-OS jobs set up BIOS, RAID, BMC, and DRAC, and apply Dell Update Packages (DUPs)  
2 Operating system installation jobs install operating systems using scripted or image-based 

installs 
3 Post-OS configuration jobs update firmware settings and drivers with Dell Update Packages 

(DUPs) 
4 Dell sample jobs with additional Dell tools and utilities
Deployment jobs can be run remotely for a single server or up to several hundred servers.

For complete instructions about using the Deployment Console to remotely manage servers and 
other computer devices, see the Deployment Solution Help and Deployment Solution Product Guide.

Deployment Jobs for Dell Servers
Deployment Solution for Dell servers imports deployment jobs that are organized into folders 
associated with the basic phases of server deployment. Each folder includes different deployment 
jobs to run based on your server provisioning and deployment strategy. 

The Deployment Solution for Dell servers jobs are designed to be run on any model of server 
supported by the Dell DTK. The deployment job will automatically assign the right tasks for the 
server model and operating system using the required Dell tool.

Caution: The Dell Sample jobs provide additional Dell server tools that may damage your server if 
not executed properly. Make sure that the correct parameters are provided when flashing the BIOS 
or running other utility programs provided in the Dell Deployment Toolkit and that all prerequisite 
requirements are met according to Dell documentation.
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Installation 

Altiris® Deployment Solution™ for Dell servers can be installed in one of two ways:

Combined Installation: For customers without an existing Deployment Solution installation, the 
combined installation first installs Deployment Solution and then installs the Deployment Solution 
for Dell servers add-on.

Add-on installation: For customers with Deployment Solution already installed, this installs 
Deployment Solution for Dell servers to an existing Deployment Server.

This section contains instructions for installing and configuring Deployment Solution for Dell 
servers using either a combined or add-on installation.

• “Requirements” on page 7
• “Installation Instructions” on page 8

Requirements
System Requirements
Altiris® Deployment Solution™ software provides the infrastructure and core functionality used by 
Deployment Solution for Dell servers. Before using this product, you should be familiar with the 
functionality and requirements of Deployment Solution.

• Deployment Solution 6.9 SP1. Additionally, your Deployment Share and Deployment Server 
must be on the same computer and installed into the same folder. See the Deployment Solution 
documentation at http://www.altiris.com/support/documentation.

Supported Dell Servers
This release provides support for the servers included in version 2.6 of the Dell OpenManage 
Deployment Toolkit (DTK).

Operating System Installation Files for Scripted Installations
Installation files are copied from your installation disks to a file share to automate scripted 
installations. During initial configuration, you are prompted to provide the installation files for each 
operating system you want to deploy using scripted installations.

Dell Server Assistant CDs or Dell System Build and Update Utility DVDs for Windows 
Scripted Installations
Drivers for each of your Dell server models can be located and copied automatically from your Dell 
Server Assistant CDs or Dell System Build and Update Utility DVDs. This eliminates the need to 
manually collect and provide the correct drivers to perform scripted installations.

NFS, FTP, or HTTP File Server to Perform Linux Scripted Installations
Linux scripted installations use installation files hosted on a remote server. To set up a server to host 
these files, follow the instructions provided with your distribution or search the Altiris 
Knowledgebase.
Deployment Solution for Dell Servers Product Guide 7
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During initial configuration, you are prompted for the Dell Server Assistant CDs that support your 
systems (supported systems are listed on the front of each disk). If you do not have these disks 
available, you can download images from ftp://ftp.dell.com/sysman/.

Supported Platforms for Scripted Installations
Jobs are provided to perform scripted installations of the following operating systems:

• Windows 2008 Server (all versions, 32-bit and 64-bit)
• Windows 2003 Server (all versions, 32-bit and 64-bit)
• Windows 2000 Server and 2000 Advanced Server
• Red Hat* Enterprise Linux AS 3 and 4 (all versions, 32-bit and 64-bit) 
• Red Hat Enterprise Linux ES 3 and 4 (all versions, 32-bit and 64-bit)
• Red Hat 5 and Red Hat 5 Advanced Platform (32-bit and 64-bit)
• SUSE* Linux Enterprise Server 10 (32-bit and 64-bit)

Installation Instructions
Complete the installation instructions in the following sections:

• “Gathering the Installation Files” on page 8
• “Performing the Installation” on page 9
• “Reviewing Deployment Solution Settings” on page 9

Gathering the Installation Files
1 Browse to www.altiris.com/download.aspx and select Deployment Solution for Dell Servers from 

the product list. After accepting the license agreement, the download page appears.
2 From the download page, download:

• Deployment Solution for Dell Servers - Dell Servers add-on only for an add-on installation.
• Deployment Solution for Dell Servers - Combined Deployment Solution and Dell Servers add-on 

for a combined installation.
3 From the download page, download Deployment Solution for Dell Servers Supplemental Files.
4 Unzip the contents of the files you downloaded in the previous steps to an installation folder on 

your server (such as c:\installation).
5 (Combined installation only) To install the Linux and WinPE preboot environments, also 

download Linux and FreeDOS Automation Environment for Deployment Solution (32-bit and 64-bit) 
and/or WinPE Automation Environment for Deployment Solution (32-bit or 64-bit). Download and 
save the preboot installation files to the installation folder.

The installation folder should contain:

• Altiris_DeploymentSolutionWin_x.exe (combined installation only)
• BDCgpl_x.frm (combined installation only)
• Altiris_DS_Preboot_WinPE_x.exe (combined installation only)
• oeminstall.ini (combined installation only)
• DeploymentForDellServers_x.exe
• DeploymentForDellServers_xDocs.docs
• Deployment_for_Dell_x_Supp.supp (note: Internet Explorer might add a .zip extension to 

this file when downloading. If this occurs, please remove this added .zip extension. Do not 
unzip this file.)

• DellDeployment.pdf
Deployment Solution for Dell Servers Product Guide 8
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• Readme.txt

You now have the files required to perform the installation.

Performing the Installation
Complete the instructions for your selected installation method:

• “Performing a Combined Installation” on page 9
• “Performing an Add-on Installation” on page 9

Performing a Combined Installation
1 Launch the Deployment Solution setup program (Altiris_DeploymentSolutionWin_x.exe) from 

the installation folder and select Extract and Execute.
2 When prompted with the Configure Boot Disk Creator dialog, browse to the BDGgpl.frm file you 

downloaded to install the Linux preboot.
3 When the Deployment Solution installation completes, ensure that Install Dell Add-on is selected 

and click Finish.
4 When the add-on installation completes, the Configuration Wizard starts. You must complete 

configuration before using any of the Deployment Solution for Dell servers features. For 
complete configuration instructions see “Initial Configuration Using the Configuration Wizard” 
on page 11.

Performing an Add-on Installation
On the computer hosting Deployment Server:

1 Launch the Deployment Solution for Dell installation program 
(DeploymentForDellServers_x.exe) from the installation folder.

2 When the add-on installation completes, the Configuration Wizard starts. You must complete 
configuration before using any of the Deployment Solution for Dell servers features. For 
complete configuration instructions, see “Initial Configuration Using the Configuration Wizard” 
on page 11.

Reviewing Deployment Solution Settings
Review the following and make the necessary configuration changes to Deployment Solution.

• “Configuring Deployment Console Settings” on page 9
• “Configuring Initial Deployment Settings” on page 10

Configuring Deployment Console Settings
To configure Deployment Console settings
1 To open the Deployment Console, click Start > Programs > Altiris > Deployment Solution > 

Console.
2 Click View > Shortcuts View, and then click the Resources bar at the bottom of the shortcuts 

pane. This view allows quick drag-and-drop access to resources such as saved image files. You 
can drag images from this folder directly to the server icons in the Computer pane. 

3 Click Tools > Options. Click the Global tab. Check the Synchronize display names with Windows 
computer names check box. This forces all server icons to be named with the NetBIOS name of 
the server they represent. Clearing this option allows the console name to be different from the 
server name.
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Configuring Initial Deployment Settings
Deployment Server includes a safety feature to prevent a managed server from being accidentally 
imaged when running a PXE Initial Deployment job. By default, this safety feature is enabled. You 
can choose to disable this safety feature to run deployment jobs from the target server, as opposed 
to running jobs from the Deployment Console. 

To configure initial deployment
1 In the lower left-hand section of the Deployment Console, double-click Initial Deployment.
2 Click the Advanced tab at the top of the window.
3 Clear the Servers check box. Click OK.
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Initial Configuration Using the Configuration Wizard

After installation, the Configuration Wizard starts automatically. The Configuration Wizard:

• Copies the mass storage and plug-and-play drivers needed to perform Windows scripted 
installations on the Dell server models in your environment. These drivers are located and copied 
automatically from your Dell Server Assistant CDs.

• Copies the operating system installation files needed to perform scripted installations.
• Lets you enable automatic static IP assignment for BMC and DRAC devices.
• Generates PXE boot images, or if not using PXE, generates automation configurations for use 

with automation partitions or boot media.
• Generates a basic set of jobs based on the settings you selected 
To run the Configuration Wizard again, in the Deployment Console, select Tools > Dell Tools > 
Configuration Wizard.

Step 1: Select Models for Windows Scripted Installations
For each model you select from the list, the mass storage and plug-and-play drivers needed to 
perform Windows scripted installations are copied from your Dell Server Assistant CDs.

To select models
1 Select each model on which you want to perform Windows scripted installations. 
2 After selecting each server, click Install Support. The configuration wizard prompts you to 

provide a Dell Server Assistant CD which supports each selected model. After the necessary files 
are located and copied, the check box for a selected system is grayed out.

3 Click Next.

Step 2: Provide Operating System Files
Providing your operating system source files lets you quickly deploy jobs to perform scripted 
installations.

To provide operating system files
1 Select each operating system you want to deploy using a scripted installation.
2 Click Install OS Support. You are prompted to provide the operating system source files for each 

selected operating system. After the necessary files are located and copied, the check box for a 
selected operating system is grayed out. After all necessary files are copied, Next is enabled.
In most cases, you simply need to select the drive containing the installation disk. The disk is 
validated by locating the following path in the selected location:

• Windows 2008 32-bit and 64-bit: \sources\setup.exe
• Windows 2000 and 2003 32-bit: \i386\winnt.exe
• Windows 2000 and 2003 64-bit: \AMD64\winnt32.exe
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• Red Hat: \isolinux\vmlinuz
• SuSE: \boot\i386\loader\linux
• SuSE 64-bit: \boot\x86_64\loader\linux
For example, if the Windows 2003 Server disc is in drive D, you simply select the root of the 
drive. According to the previous table, the Configuration Wizard verifies that this location 
contains an i386 folder with a winnt.exe file.

3 (Red Hat 5 only) Provide the installation code you received if you purchased a support package. 

Step 3: Firmware IP Address Configuration
Typically, DHCP is used to assign IP addresses to BMC and DRAC configuration cards. Most 
DHCP servers allow you to make static assignments for specific devices if needed. 

If you would prefer to assign a specific IP address directly in the device configuration file, select the 
Static assignment option. 

The Static option provides an IP insertion process using Deployment Solution tokens. After a BMC 
or DRAC configuration file is captured, the IP address is replaced with a token string. When this 
configuration file is deployed to a server, this token is automatically replaced with a unique IP value 
from a reserved range.

To use Static IP configuration
1 Select Static.
2 Provide a reserved IP range from which IP addresses are assigned. Additional ranges can be 

provided later using the Configuration Utility.
We suggest also reserving these ranges on your DHCP server to ensure that you won't have conflicts.

Step 4: Preboot Environments
Select the preboot environments you want to use to run configuration jobs.

If you select a preboot environment that is not yet installed in Deployment Solution, you are 
prompted to install the environment. Installations for each of the preboot environments are available 
on the Deployment Solution for Dell Servers download site. See “Gathering the Installation Files” 
on page 8.

If you are using PXE, click Yes when prompted to install the PXE image.

Step 5: Build Basic Jobs
Click Create Jobs to generate jobs based on information gathered in previous steps of the 
Configuration Wizard. These jobs include firmware configuration and scripted operating system 
deployment.

If you would like to open the Job Builder to create custom RAID configuration or other advanced 
jobs, leave the Launch the Job Builder after creating your basic jobs option selected.
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Update Settings Using the Configuration Utility

The Configuration Utility lets you view and update individual configuration settings. In the 
Deployment Console, select Tools > Dell Tools > Configuration Utility to launch this utility.

• “Server Models” on page 13
• “Reserving IP Ranges for BMC and DRAC” on page 14
• “Discovering Servers with Remote Power Control” on page 14
• “Configuring Scripted OS Deployment” on page 15

Server Models
This tab lets you:

• Download and delete Dell Update Packages for your server models.
• Edit captured DRAC, RAID and system configuration files.
• Configure job debugging levels and view job logs.

To download update packages
Deployment Solution for Dell servers lets you easily download available Dell Update Packages 
(DUPs) for supported Dell server models. These updates can then be installed as part of your 
deployment job.

When downloading DUPs, make sure you select the correct version based on the enviroment in 
which the DUP will be applied.

The DUP jobs contained in the Pre OS-Deployment Jobs folder are executed in the Linux 
automation environment. Therefore, these jobs require DUPs that will run in Linux. When 
downloading DUPs for these jobs, make sure you select the Linux versions.

The DUP jobs that are contained in the Post OS-Deployment Jobs folder are applied in the 
production operating system. Therefore, these jobs require DUPs that will run in the production 
operating system installed on the server. Make sure you select the version corresponding with the 
installed operating system. 

1 Click Get DUP Catalog.
2 In the Filter by drop down, select In DUP Catalog. This displays server models with updates listed 

in the catalog.
3 Select and download only the specific updates you want to install. We do not recommend 

downloading all update packages for a server model. This causes the download process to take 
much longer than necessary, and older update packages might be included.
You need to make sure that any updates you download are compatible with your currently 
installed versions and are not older than what you currently have installed.
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To edit captured configuration files
1 Click Edit.
2 Browse to the DRAC, RAID, or system folder.

Select the configuration file corresponding to the server model you would like to configure. For 
example, pe1750.ini contains settings for PowerEdge 1750 servers.

To delete downloaded DUPs
This deletes all DUPs for the selected server model. This feature does not delete only a single DUP 
even if only one DUP was selected.

1 Select a server model from the list.
2 Click Delete DUPs.

Reserving IP Ranges for BMC and DRAC
This tab lets you:

• Turn automatic IP insertion on and off.
• Define IP ranges for automatic insertion into BMC and DRAC configuration files.
By reserving ranges of IP addresses on the IP Ranges tab, Deployment Solution for Dell Servers can 
automatically insert a unique IP address into a BMC or DRAC configuration file during 
configuration.

You must select the Replace IP address with token in captured configuration files check box to enable 
this feature.

To add IP ranges
1 On the IP Ranges tab, click Add.
2 Select the type and provide an IP range.
Multiple ranges can be added. When the last IP address is used from a given range, the next range 
defined in the list is used. 

We recommend also reserving these ranges on your DHCP server to ensure that you won't have 
conflicts. 

Troubleshooting Tips
The IP insertion process uses Deployment Solution tokens. After a BMC or DRAC configuration 
file is captured, the IP address is replaced with a token string. When this configuration file is 
deployed to a server, this token is dynamically replaced with an IP value from the reserved range.

If BMC or DRAC controllers are not being configured with the new IP addresses, complete the 
following:

1 On the Server Models tab, click Edit.
2 In the dialog, open the DRAC folder and select the configuration file corresponding to the server 

model you want to configure. 
3 In this file, make sure the line containing the new IP address token is not commented out.
For additional details on tokens, see the Deployment Solution help.

Discovering Servers with Remote Power Control
This tab lets you:

• Enable advanced power control options for servers in the Deployment Console.
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Power control lets you discover servers on your network that support remote power control and then 
add control options to the Deployment Console. Perform this task after you add managed servers to 
your Deployment Console.

To discover servers
1 On the Power Control tab, click Discover, then select a discovery method, and then provide:

• The beginning IP to query
• The end IP to query
• The user name and password for the BMC or DRAC card being queried.

2 Click Discover.
If a server is discovered in the specified IP range, Dell-specific power control options are enabled in 
the Deployment Console. To access these options, right-click on the server in the Deployment 
Console and select power control.

If you receive an “entry not found” message in the discovery log, it indicates that a server responded 
to the request but is not in the Deployment Console.

See “Using Power Control” on page 26 for an example using power control.

Configuring Scripted OS Deployment
This tab lets you:

• Set up configurations for scripted installations. Each configuration has an associated source file 
location and answer file. Multiple configurations can use the same source file location. 

To create a scripted installation configuration
1 Click Add and select an operating system.

Browse to the operating system installation files. Files can be located on a disc, file system, or 
an existing location on the Deployment Share. n most cases, you simply need to select the drive 
containing the installation disk. The disk is validated by locating the following path in the 
selected location:

• Windows 2008 32-bit and 64-bit: \sources\setup.exe
• Windows 2000 and 2003 32-bit: \i386\winnt.exe
• Windows 2000 and 2003 64-bit: \AMD64\winnt32.exe
• Red Hat: \isolinux\vmlinuz
• SuSE: \boot\i386\loader\linux
• SuSE 64-bit: \boot\x86_64\loader\linux
For example, if the Windows 2003 Server disk is in drive D, you simply select the root of the 
drive. According to the previous table, the Configuration Wizard verifies that this location 
contains an i386 folder with a winnt.exe file.

2 Provide the following: 
• For Windows, a volume license key. 
• For Linux, the installation source location (NFS, FTP, or HTTP) and authentication 

credentials to the Deployment Server if you want to mount the Deployment Share and install 
ADLAgent when the installation completes.
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To edit an answer file
Editing an answer file lets you change settings such as the administrator password (default password 
is altiris), computer name, and time zone. Deployment Solution token replacement may be used.

1 Select a configuration and click Answer file. The answer file format depends on the operating 
system:
• For Windows, the answer file is named unattend.txt or unattend.xml and includes the license 

key. If multiple license keys are needed, refer to the Deployment Solution documentation for 
help using tokens.

• For Red Hat Linux, the answer file is named ks.cfg and includes the setting for installation 
source. The bootloader and root passwords are encrypted in the answer file and may be 
changed after installation completes.

• For SUSE Linux, the answer file is named autoinst.xml.
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Define Custom Jobs Using the Job Builder

The Deployment Solution for Dell Servers Job Builder helps you create custom jobs to perform one 
or more of the following tasks:

• Set a starting point for blade re-deployment
• Configure system BIOSs
• Configure DRACs
• Configure RAID controllers
• Partition Hard Drives
• Perform Scripted OS installations
The Job Builder provides additional options not available with the pre-generated jobs. Additionally, 
the Job Builder provides a rule-based, graphical RAID configuration utility to greatly simplify 
RAID set up.

Using the Job Builder
Each option on the initial screen of the Job Builder represents a task you can perform in a custom 
job. These tasks are performed in the order they are listed.

For example, to create a job that configures the system firmware then deploys a scripted installation, 
you would select Configure System Firmware and Scripted OS Install.

To create a rule-based RAID configuration job, you would select Configure RAID.

When you click Build Job, a job is generated to perform the configuration you selected. After you 
build a job, it cannot be opened in the Job Builder. Additional changes must be performed directly 
in the generated job or re-created in the Job Builder.

Re-Deployment Starting Point
This option marks the starting point for blade re-deployment. When a blade is replaced, any jobs 
applied after this point are executed on the replacement.

Configure System Firmware
System firmware can be configured using configuration files from one of three sources:

Generic model configure file: The job automatically selects the configuration file within the 
Dell\configfiles\system folder that is named after the model number of the server. (This functions 
the same as the generated configuration job.)

Existing Computer configuration file:  The job automatically selects the configuration file within 
Dell\configfiles\system folder that is named after the machine ID of the target server.

From File: The job uses the specified file on all servers.
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Configure DRAC Firmware
DRAC firmware can be configured using configuration files from one of three sources:

Generic model configure file: The job automatically selects the configuration file within the 
Dell\configfiles\DRAC folder that is named after the model number of the server. (This functions 
the same as the generated configuration job.)

Existing Computer configuration file:  The job automatically selects the configuration file within 
Dell\configfiles\DRAC folder that is named after the machine ID of the target server.

From File: The job uses the specified file on all servers.

Configure RAID
See “Create Custom RAID Configurations” on page 19.

Prepare Disk
This lets you clear the MBR and partition table and install a Dell Utility Partition before performing 
a scripted installation.

Deploy OS
For a scripted installation, this lets you select a target drive, an installation configuration, and 
optionally a different answer file than the one associated with the configuration.

For an image-based installation, this lets you select an image file.
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Create Custom RAID Configurations

Deployment Solution for Dell Servers provides a graphical RAID configuration tool which lets you 
configure server RAID controllers based on rules you define. These rules are based on the number 
of controllers on a server and the number of disks on each controller.

For example, you could define a rule that matches a server with one controller with three disk drives. 
When a server matching this configuration is encountered, the RAID is configured according to the 
rule.

To create a rule-based RAID configuration
1 In the Deployment Console, click Dell Tools > Job Builder. 

RAID configuration tasks can be one task in a more comprehensive custom job or the only task 
in a custom job.

2 Select Configure RAID. The Configure RAID Task window appears. See:
• “Configure RAID Task Overview” on page 19 for a description of this window.
• “Creating Server RAID Definitions” on page 20 for instructions on creating RAID 

configurations.

Configure RAID Task Overview
The RAID Task Overview window graphically represents the RAID server configurations you have 
defined and the RAID settings to apply when each configuration is encountered. By default, the 
window is blank with no server configurations defined.

The following shows a sample server configuration and RAID settings to apply:

Graphic Description
Represents a server.
No RAID controllers are currently defined for this server.

Represents a RAID controller. The number of disks on the controller 
is displayed.
This controller has 2 disks.

Server

RAID Controllers

RAID Settings to ApplyMatching Mode
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Multiple server definitions can be added, each with their own controller definitions and RAID 
settings. 

Constraints on RAID Arrays
The following constraints apply when creating RAID arrays. The RAID controller might impose 
additional constraints, and some controllers might support fewer disks.

Creating Server RAID Definitions
There are 5 basic steps to creating a server definition:

• Step 1: Add a server definition.
• Step 2: Select a matching rule.
• Step 3: Add one or more controllers.
• Step 4: Select the way you want to group the disks on each controller.
• Step 5: Select a configuration to apply to each group.

To create a server RAID definition
1 Click Add Rule. The RAID Configuration Rule window appears with a blank server definition.

2 Click Add Controller and select the number of disks to match on the controller. Repeat to add 
additional controllers.

Represents the RAID configuration that will be applied to the corre-
sponding controller (the first definition applies to the first controller, 
and so on).
This indicates that the corresponding RAID controller will be config-
ured as RAID 1 (mirrored pair).
Match by physical order (default). See “Match by Physical Order” on 
page 21.

Match by priority. See “Match by Physical Order” on page 21.

Raid Type Constraints
RAID 0 1-32 disks.
RAID 1 2 disks.
RAID 5 3-32 disks.
RAID 10 4-16 disks, must be even number.
RAID 50 6-98 disks, must be even number. 
Global Hotspare (HS-
G)

Cannot be the first disk group. Cannot follow a disk group that is as-
signed no RAID.

Dedicated Hotspare 
(HS-D)

Cannot be the first disk group. Cannot follow a disk group that is as-
signed no RAID or RAID 0. 

Graphic Description
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3 In the Raid configuration to apply section, select a controller and click Configure.

4 Select Overwrite the current RAID configuration with the following groups. If you do not select this 
setting, a controller matching this definition is skipped. Selecting to not overwrite existing 
configuration is useful when you already have a configured RAID on the system.

5 Select a controller and click Remove group if you want to create a new disk grouping. The disks 
on each controller do not have to be grouped together. For example, on a controller with 6 disks, 
2 disks could be configured as a RAID 0 and the remaining 4 disks could be configured as RAID 
5.
After the group is removed, click Add group to define a new group. In this example, the controller 
with 6 disks in the previous example is separated into two groups:

6 If you did not remove the default disk group, select a disk group and click Properties to specify 
the RAID type for each disk group.

7 When finished, click OK and then click OK on the RAID Configuration Rule window. Your rule 
appears in the Configure RAID Task window:

A rule-based RAID task can contain multiple server configurations to match. Repeat this procedure 
to add additional server configurations.

Match by Physical Order
Controllers are matched in the order shown (starting from the left) and must match the server 
exactly. The only exception is when the Match any remaining controllers on the server option is 
selected for a controller. In that case, a controller can be matched with any number of disks.

RAID controller order is determined by the Controller ID number produced by raidcfg.  
Occasionally Controller IDs for multiple controllers are non-contiguous, in which case they will be 
evaluated as if they were contiguous.  For Example, if raidcfg reports three controllers with IDs 0, 
3, and 5, those controllers will be treated as controllers 1, 2 and 3 respectively by the rule evaluator.

To help understand the way matching works, two servers are used as examples:

• A PowerEdge 1955 Blade server with one RAID controller. The controller has two disks.
• A PowerEdge 2950 server with two RAID controllers. The first controller has two disks; the 

second controller has six disks.
Matching by physical order is generally more restrictive. To use physical order to match these 
servers requires two separate server definitions.

The PowerEdge 1955 servers would be matched using physical order by the following:
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The PowerEdge 2950 servers in this example would be matched using physical order by the 
following:

When evaluated, the first rule would match the 1955s, but not the 2950s because the 2950s have two 
controllers. The second rule would match only the 2950s and not the 1955s because there are two 
controller definitions.

Using physical order is useful if you have existing RAID configurations you want to preserve. For 
example, if you know the first controller on a system contains an operating system, you could match 
by physical order then do not specify a RAID configuration for this control. If no definition is 
specified, no configuration occurs.

Physical order is also useful if you need to configure two controllers with the same number of disks 
with different settings.

Match by Priority
Controller definitions represent a priority list that is evaluated from left to right. Controllers are 
treated independently (the first controller defined does not need to be controller 1 on the system). To 
change priority, change the order of the controllers.

Every controller on the system must be matched. There can be server definitions in the rule that are 
not used, but each controller on the system must match a definition on the rule.

The same two servers used in the match by priority section are used as examples:

• A PowerEdge 1955 Blade server with one RAID controller. The controller has two disks.
• A PowerEdge 2950 server with two RAID controllers. The first controller has two disks; the 

second controller has six disks.
Using a priority match, both server types can be configured using a single server definition:

When this is evaluated on the PowerEdge 1955s, the rule first checks for a controller with 2 disks. 
When controller 1 is discovered with 2 disks, these disks are configured. Next, the rule checks for a 
controller with 6 disks and performs no configuration because it was unable to find a matching 
controller.

When this is run on the PowerEdge 2950s, the rule first checks for a controller with 2 disks, and 
configures these disks, then checks for a controller with 6 disks and configures these disks.

In priority mode, you can also allow a single controller definition to be used more than once on a 
system. For example, if you have a server with 2 controllers with 5 disks each, you could create one 
5-disk controller in the Raid configuration rule window and select the Allow controller definitions to 
be matched with more than one physical controller option. When run both controllers are matched and 
configured using the single definition.
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Perform Server Management Tasks

This section contains walkthroughs of common server management tasks:

• “Deploying a Complete Server” on page 23
• “Configuring RAIDs Using Physical Mode Matching” on page 24
• “Configuring RAIDs using Priority Mode Matching” on page 25
• “Copying a RAID Configuration” on page 26
• “Using Power Control” on page 26
• “Applying a Dell Update Package” on page 27
• “Changing Hardware Settings” on page 27
• “Using the Sample Jobs” on page 28

Deploying a Complete Server
A complete server deployment involves starting with an unconfigured system with no operating 
system (“bare-metal”), configuring the BIOS, DRAC/BMC, and RAID settings, and then installing 
an operating system.

Using this job, you can take a server from any state whether it be freshly installed in the rack or 
currently in use for some other purpose, cleared completely, reconfigured (firmware and software) 
and installed to an OS. 

Deploying servers using a bare-metal job has several advantages:

• Settings are consistent among a large number of servers.
• Servers of any supported model can be deployed using the same job.
• Drivers collected from Dell Server Assistant CDs during “Initial Configuration Using the 

Configuration Wizard” on page 11 are applied automatically.
• Dell Utility partitions can be installed automatically.

Important
Bare Metal to scripted operating system jobs configure your firmware (BIOS/BMC/DRAC) if 
Generic Model Configuration files are present on your Deployment Share in the dell\configfiles 
folder. 

For example, if a file called pe2950.ini exists in the DRAC folder, the settings in that file are used 
to configure the DRAC on all PowerEdge 2950 servers receiving this job. If you do not want your 
firmware configured, either delete the configuration files, or create a new custom Scripted OS 
Deployment Job using the Job Builder.
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To perform a bare-metal deployment
1 In the Deployment Console, browse to the OS Deployment Jobs folder within the Job Pane. If you 

do not see bare metal to scripted OS jobs, you must perform some configuration. See 
“Configuring Scripted OS Deployment” on page 15.

2 Drag and drop the deployment job on one or more servers.

Configuring RAIDs Using Physical Mode Matching
This example assumes you are familiar with creating rule-based RAID configurations. For more 
information, see “Create Custom RAID Configurations” on page 19.

Scenario:
An administrator has the following servers to configure:

• 20 Dell 2950 servers each containing two controllers. The first has 2 disks; the second has 6 
disks.

• 30 Dell 1955 blade servers each containing two disks on a single controller.

The administrator decides to configure RAIDs on each server according to the following:

To define a matching rule-based configuration
1 In the Deployment Console, click > Tools > Dell Tools > Job Builder.
2 Select Configure RAID. The Configure Raid Task window appears.
3 Click Add Rule to define the first server configuration.
4 Click Add Controller and change the number of disks to 2. Click OK.
5 In the Raid configuration to apply section, select the controller and click Configure. The 

Configure RAID controller window appears.
6 Enable Overwrite previous RAID configuration with the following groups. 
7 Select the disk group and click properties. Select RAID 1 and click OK.
8 Click OK, and then click OK again. The first rule is defined and matches the configuration 

described for the 1955s.
9 Click Add Rule to define the second server configuration.
10 Click Add Controller and change the number of disks to 2. Click OK.
11 Click Add Controller and change the number of disks to 6. Click OK

12 In the Raid configuration to apply section, select the controller with 2 disks and click Configure. 
The Configure RAID controller window appears. Configure this controller as RAID 1.

13 Click OK until the Raid Configuration Rule window appears.
14 The first 5 disks will be configured as Raid 5, and the remaining disk will be configured as a 

global hotspare. Therefore, we need to ungroup the group of 6 disks. Select this group and click 
Remove Group.

15 With the disks ungrouped, click Add Group and set the number of disks in the group you are 
adding to 5. Select RAID 5 and click OK.

16 Click the remaining disk (which is ungrouped), and use Add Group to assign this single disk to 
be a global hotspare. Click OK until the Raid Configuration Rule window appears.
In the Configure Raid Task window, there are two rules defined. The first matches the 1955s, 
and the second matches the 2950s. Click OK and build this job.

Server RAID Configuration to Apply
2950s Controller 1, 2 disks in RAID 1

Controller 2, 5 disks in RAID 5, 1 disks as a global hotspare
1955s Controller 1, 2 disks in RAID 1
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Configuring RAIDs using Priority Mode Matching

This example assumes you are familiar with creating rule-based RAID configurations. For more 
information, see “Create Custom RAID Configurations” on page 19.

Scenario:
An administrator has the following servers to configure:

• 10 Dell PowerEdge 1955s - 1 Controller with 2 disks
• 12 Dell PowerEdge 6950s - 3 Controllers with 4, 6 and 2 disks (unsure of order of controllers)
• 40 Dell PowerEdge 6950s - 2 Controllers with 2 and 6 - 10 disks (unsure of order of controllers)
• 25 Dell PowerEdge 1750s - 2 Controllers with 3 disks each
• 7 Dell PowerEdge 6850s - 2 Controllers with 5 and 1 disks (unsure of order of controllers)

The administrator decides to configure RAIDs on each server according to the following:

This RAID configuration job would be very difficult using physical mode matching, especially since 
the administrator is unsure of the order of the controllers on several of the systems.  For instance, if 
the administrator made a rule in physical mode for 2 controllers, the first having 5 disks and the 
second having 1 disk, but the server had 1 disk on the first controller and 5 disks on the second, the 
rule would not match, and no configuration would take place.

But with priority matching, this is not an issue, since the administrator makes a rule based on the 
number of disks found, not on controller number or position.  In fact, the configuration for all of 
these systems can be accomplished by creating a single rule.

By starting with definitions for the largest number of disks, and working down, the administrator can 
take advantage of the priority mode's characteristics of using the first definition that matches:

• If 10 disks, then configure all 10 disks as RAID 10
• If 8+ disks, then configure first 8 as RAID 10, and any remaining disks as hotspares
• If 6+ disks, then configure first 6 as RAID 10, and any remaining disks as hotspares
• If 5 disks, then configure all 5 disks as RAID 5
• If 4 disks, then configure the first 3 as RAID 5, and the fourth disk as a hotspare
• If 2+ disks, then configure with first 2 disks RAID 1, and all remaining disks as global hotspares
• If 1 disk, then configure as RAID 
After running this rule on all these servers they would then contain the RAID configuration outlined 
in the following table:

# of Disks RAID Configuration to Apply
1 RAID 0
2 RAID 1
3 RAID 1 (2 disks) + 1 hotspare
4 RAID 5 (3 disks) + 1 hotspare
5 RAID 5 (5 disks)
6+ RAID 10 (with odd-numbered disks as a global hotspare).

Server Disk Configuration RAID Configuration
10 Dell PowerEdge 
1955

1 Controller with 2 disks One RAID 1 virtual disk containing two 
disks.

12 Dell PowerEdge 
6950s

3 Controllers with 4, 6 and 2 
disks (unsure of order of 
controllers)

One RAID 10 virtual disk
One RAID 1 virtual disk
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Copying a RAID Configuration
This scenario demonstrates capturing a RAID configuration from one server and applying it others.

Scenario: 
An administrator has 100 Dell 6850s all with the same number of RAID controllers and disks per 
RAID. The administrator set up a custom RAID configuration on one of these 100 servers and wants 
that same configuration applied to the remaining 99.

To capture and apply RAID configurations
1 Run the Get Raid Configuration File job or Get All Configuration Files job on the server that has the 

RAID set up that you want to duplicate. Wait until the job finishes.
2 Find the machine ID of the system where you just executed the get configuration files job. This 

can be done in the Deployment Console by right-clicking on the computer and going to 
properties. This example uses a machine ID of 5000001.

3 Launch the Job Builder and click Configure Raid.  A window appears with RAID configuration 
options.  Click the radio button labeled From File. Click Browse and select the file that 
corresponds to the Machine ID located earlier (5000001.ini).

4 Click OK and then click Build Job.  Provide a name and description and click OK. Close the Job 
Builder.

5 Click the refresh icon in the Deployment Console. The job you created appears in the Job Builder 
folder. Run this job on additional servers to apply the RAID configuration.

Using Power Control
Deployment Solution for Dell Servers has a feature called Power Control that extends the default 
Power Control feature included with Deployment Solution.  Deployment Solution lets you restart 
and shutdown computers in the production operating system with the Deployment Agent installed. 
The power control features of Deployment Solution for Dell Servers removes these limitiations by 
using DRAC or BMC cards out-of-band.  Deployment Solution for Dell Servers provides these 
additional commands:

• Dell - Power On
• Dell - Power Off
• Dell - Reset
• Dell - Launch Interface (DRAC only)
These commands are sent out-of-band through either a DRAC or a BMC card.  As long as your 
servers have at least one of these devices (and it is connected to the network), you can use this 
feature.

40 Dell PowerEdge 
6950s

2 Controllers with 2 and 6 - 
10 disks (unsure of order of 
controllers)

One RAID 1 virtual disk
One RAID 10 virtual disk which may or may 
not have a global hotspare

25 Dell PowerEdge 
1750s

2 Controllers with 3 disks 
each

Two RAID 1 virtual disks with one global 
hotspare each

7 Dell PowerEdge 
6850s

2 Controllers with 5 and 1 
disks (unsure of order of 
controllers)

One RAID 0 virtual disk
One RAID 5 virtual disk

Server Disk Configuration RAID Configuration
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To enable power control
Since these devices use their own IP address, which is not stored by the Deployment Agent, you 
must discover these devices using the Configuration Utility. Follow these steps to enable the 
additional power control features.

1 Make sure that all servers on which you want to enable power control appear in the Deployment 
Console.

2 Click Tools > Dell Tools > Configuration Utility, and select the Power Control tab.
3 If you know the machine ID and IP addresses, you can enter this information manually using 

Add. Use Discover to search a range of IP addresses for these devices.
4 After the discovery completes, view the details of the discovery process by clicking log on the 

lower part of the Power Control tab.  If an IP address says Entry not found, this indicates that a 
device was discovered but that the device does not exist in the Deployment Console.

5 After a server is discovered, power control features are automatically enabled. Select a server, 
right-click, and select Power Control to use these features.
If the DRAC or BMC IP address changes for any reason, you need to rediscover or update to re-
enable power control.

Applying a Dell Update Package
Scenario:
An administrator would like to make sure that all of the 1855 Blade servers are using the latest BIOS 
version.

To apply a Dell Update Package 
1 Open the Configuration Utility by going to Tools > Dell Tools > Configuration Utility.
2 Change the Filter to In DUP catalog, and click Get DUP Catalog.  This downloads a catalog that 

contains all the updates available for all servers supported by the DTK.  After the catalog is 
downloaded the list populates to the left.
We recommend downloading the DUPs from the Dell website, though you may optionally use a 
Server Update Utility CD.  To do this, click Options in the lower right-hand portion of the Server 
Models tab, click Local and provide a path to the CD.

3 With the list populated, you can browse to the the 1855 > Windows > BIOS > Dell Server System 
BIOS, A04.  This indicates that there is a DUP that is available to run on a Windows Production 
environment that will update the BIOS to version A04.

4 Click the entry, and then click Download DUP. Wait until the DUP is downloaded.
5 You may now drag the Update BIOS and Reboot job to your 1855s.  This copies the DUP down 

to the server, and then runs it.
DUPs automatically check to see whether they are actually upgrading firmware before they perform 
it.  Thus, the DUP will only upgrade if an upgrade is necessary.   

The DUP remains stored on the Deployment Share after the DUP is applied.  This means that if later 
another package is downloaded that is newer than the current one, both the old package and the new 
package are executed. While this might not produce any adverse effects, it slows down the process 
of applying the DUP.  

We recommend that you delete previously downloaded DUPs before downloading updated DUPs. 
This prevents situations in which the wrong DUP is applied.

Changing Hardware Settings
Scenario:
An administrator needs to change the boot order on 500 PowerEdge 1750 servers.
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To change settings
1 Run the Get System Configuration File job on a 1750 server. After capture, this configuration 

file can be used to configure any number of 1750 servers.
2 Edit the captured system configuration file. Launch the Configuration Utility, click the Server 

Models Tab, and then click Edit.
3 Browse to system\pe1750.ini and click Open.
4 Change the bootseq value, for example:

bootseq=nic.emb.1,hdd.emb.0,cdrom.emb.0,floppy.emb.0

5 Delete all other settings below the ;do not edit information above this line unless 
you want to re-apply the setting. Leaving values you are not changing can cause settings to be 
accidentally overwritten.

6 Save your changes.
7 In the Deployment Console, assign a Configure System job to the PowerEdge 1750 servers that 

you want to receive new settings.

Using the Sample Jobs
The sample jobs provide a selection of assorted jobs you might find useful when managing Dell 
servers. Samples marked with an asterisk (*) require user modification.

Sample Job Description
Get RAID Information 
File

Generates a user-friendly printout of the disks available to the RAID 
controllers and their respective capacities. While this file cannot be 
used to configure a RAID, it is useful for inventory and determining 
current configuration.

Get System Information 
File

Retrieves the PCI bus output. This is useful to obtain hardware and 
vendor IDs for specific hardware when troubleshooting any driver is-
sues that are not resolved by the Mass Storage Driver and Plug & 
Play Driver insertion mechanism (see “Configuring Scripted OS De-
ployment” on page 15).

Uninstall OMSA Agent Uninstall the OMSA agent.  If the product code does not match the 
version of the OMSA agent you are using, it may need to be changed.

Windows – Repair 
OMSA Agent from GUID

Repair the OMSA Agent.

Apply Other Dell Update 
Package (DUP) and 
Reboot

Manually apply a Dell Update Package.

Custom RAID 
Configuration

Perform a RAID configuration using raidcfg directly.  We recom-
mend using this only if your configuration cannot be accomplished 
using the RAID task in Job Builder. See “Create Custom RAID Con-
figurations” on page 19.

Execute Dell Deployment 
Toolkit Tool

Provides a job to write a custom action of the Dell OpenManage 
Toolkit that isn’t provided by the JobBuilder.  See the Dell Open-
Manage Toolkit Command-line documentation for details.

Execute Dell Deployment 
Toolkit Tool (Template)

The template version of this job provides direct access to the DTK 
call, making the job more flexible. Using this version requires more 
knowledge of the DTK.

DRAC/IPMI Action Send other commands made available by ipmiutils or racadm to BMC 
or DRAC devices that are discovered (see “Using Power Control” on 
page 26).  See the contents of the script for details.

Enable embedded NICs 
and Reboot

Enable the embedded NICS using the Dell OpenManage Toolkit.
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Set starting point for 
re-deployment

Run this job on a blade server before running the deployment job.  
This indicates to Deployment Solution where to begin when re-de-
ployment occurs. See “Rip and Replace Process Flow” on page 30.

Wait in Dell DUP
Wait in Dell Linux
Wait in Dell WinPE

No job or tasks are performed (the Deployment Agent on the server 
blade is instructed to wait). The icon on the console changes to reflect 
that the server is waiting.

Sample Job Description
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Manage Server Blades

Replacing and Configuring Server Blades
Deployment Solution for Dell servers allows you to replace a Dell server blade in a Rack-Enclosure-
Bay unit and replicate the operating system, configuration settings, and software to a new server 
blade—this is commonly called “rip and replace.”

Server Blade Deployment
Deployment Solution allows you to manage high-density server blades with Rack/Enclosure/Bay 
(R/E/B) slots and chassis. From a Deployment Console, you can deploy and manage these space-
efficient server blades using the physical view to assign jobs to all server blades installed in the rack, 
to the enclosure, or to each bay. You can also manage each server blade directly from the logical view 
like any other server. Icons identifying the physical view of the Rack, Enclosure, and Bay are shown 
here:

Using Deployment Solution, you can employ “rip and replace” technology that allows you to insert 
a new server blade and automatically configure and deploy it exactly like the previously installed 
server blade, allowing you to replace any downed server and get it back online quickly. 

Rip and Replace Process Flow
The following is an example of the system process when running a rip and replace function for a 
server blade. 

1 A server blade is removed from Bay 2 in the enclosure.
2 A new server blade is installed into Bay 2.
3  The new server blade is powered on manually or using Wake on Lan features.
4 PXE Server checks the PXE.INI file to see if it recognizes the server or identifies it as a new 

server from the MAC address.
5 PXE Server then requests any assigned jobs from Deployment Solution.
6 Deployment Solution determines that the server blade is new and executes the blade change rule, 

which needs to be set to Re-Deploy Computer for “hands free” installation (see “Server Blade 
Change Rules” on page 32).
Note: The Server Blade Change rule is assigned in the Bay property page and is identified as an 
object in the physical view of the Computers pane. As a result, new server blades inserted into 
the bay will run with the same rules as the previously installed server blade. 

7 Deployment Solution executes the history of jobs starting from an initial Deployment Solution 
job. It will then replay all of the subsequent jobs in the server’s history, which is saved in the 
Deployment Database.
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Note: The initial Deployment Solution job can be a Distribute Disk task or from a Scripted OS 
Install task. If installing from a server script, the history will rerun from a Run Script task that 
contains a rem deployment start string. (we have a job to do this now)

8 The new server blade is then configured and deployed with the same OS and configuration 
values as the previous server blade.
Using Primary Lookup Keys in Deployment Solution: 
• One server blade can have multiple network adapters that will cause the server blade to show 

up as three new servers in the Deployment Console. For that reason, many customers use 
serial numbers as the primary lookup key. 
If you select a serial number as the primary lookup key instead of the default MAC address, 
then Deployment Solution will compare the serial number within the Deployment Database 
to determine whether the server is recognized instead of looking at the MAC address field. 
If the server is identified as new, then Deployment Solution will create a new computer ID 
for that server. If it is a recognized managed server blade that has been replaced, Deployment 
Solution will compare serial numbers (instead of the MAC address field) to determine 
whether to apply the change rule. 

• Deployment Solution can use any of the available primary lookup values—MAC Address, 
Serial Number, Asset Tag, and the UUID—to identify if the server is new or if it is a managed 
server blade already recognized by Deployment Solution with data stored in the Deployment 
Database. Comparing primary lookup key values will trigger the Change Rule for the server 
blade set in the Bays property page. The primary lookup key can be set in the Tools > Options 
> global tab > Primary lookup key field from the Deployment Console.

Rip and Replace Notes:
• The MAC Address or Dell Service Tag can be used as the unique identifier by Deployment 

Solution to determine that a rip and replace task has occurred. You can also use a Universally 
Unique Identifier (UUID) and Serial Numbers as a unique identifiers. See “Using Primary 
Lookup Keys in Deployment Solution:” on page 31.

• Complete automated rip and replace features that require no manual action on the Deployment 
Console requires a PXE Server. It is not a completely “hands free” operation without the ability 
to boot up using PXE. 

Fail-Safe Features
Deployment Solution provides fail-safe features to ensure that no server blade is mistakenly re-
imaged or redeployed using rip and replace features. For new server blades, Initial Deployment will 
not run on any type of server by default. To set up Initial Deployment for servers, you must click on 
its Advanced tab and clear the Servers check box.

Also, in the Bays properties displayed in the Deployment Console for each server blade, there are 
Blade Change Rules that can be set up to govern actions when a new blade server is detected in the 
bay. See “Server Blade Change Rules” on page 32.

Setting up New Server Blades with Initial 
Deployment
When new blades are identified in a bay, then the Initial Deployment feature can be set up to 
automatically run configuration tasks and deployment jobs when the new server boots up. To set up 
Initial Deployment, clear the Servers check box in the Advanced tab in the Initial Deployment feature 
in the Jobs pane of the Deployment Console. This allows you to run Initial Deployment on server-
class computers. Selecting the Servers checkbox allows you to avoid accidental re-imaging or 
overwriting of data and applications for workstations or servers. 

Note: When a computer not yet known to the Deployment Server is first detected, it will be placed 
in the New Computers group and run an Initial Deployment configuration set and job. However, in 
many cases, you may not want web or network servers to be automatically re-imaged without 
confirmation from IT personnel.
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Server Blade Change Rules
From the Bay property page, you can select rules to govern actions taken when a new blade server 
is detected in a selected bay. These rules are described below:

Rule Action
Re-Deploy Computer Restore a blade server using deployment tasks and configuration settings 

saved from the previous server blade in the bay. This allows you to replace 
new blades in the bay and automatically run deployment tasks from its 
deployment history. 
All deployment tasks in the bay's history will be executed starting from the last 
Distributing a Disk Image task or the Scripted OS Install task, or from any 
script (in a Run Script task) with this command: rem deployment start.

Run Predefined Job The server will process any specified job. Select a job to run automatically 
when a new server is detected in the bay.   

Ignore the Change This option allows you to move blades to different bays without automatically 
running jobs. The server blade placed in the bay is not identified as a new 
server and no jobs are initiated. If the server existed in a previous bay, the 
history and parameters for the server are moved or associated with the new 
bay. If the server blade is a new server (never before identified), then the 
established process for managing new computers will be executed.

Wait for User 
Interaction

(default) No job or tasks are performed (the Deployment Agent on the server 
blade is instructed to wait). The icon on the console changes to reflect that the 
server is waiting.
Deployment Solution for Dell Servers Product Guide 32



 

Troubleshooting

This section includes common troubleshooting topics.

• “I am experiencing job failures on some of my servers” on page 33
• “After upgrade my custom Dell jobs stopped working” on page 33
• “Power control options no longer work for some of my servers” on page 33
• “Which OEM extensions option should I select when using automation partitions?” on page 34
• “How do I restore the jobs that were automatically generated after configuration?” on page 34
• “I am getting stop errors (blue screens) during Windows scripted installations on some servers” 

on page 34

I am experiencing job failures on some of my servers
The following are general tips to troubleshoot job failures:

• Check status detail by double-clicking on the job and selecting status detail. This often contains 
explanations of the steps you need to take.

• You may also start the Configuration Utility (In the Deployment Console, select Tools > Dell 
Tools > Configuration Wizard) and click Server Models > Options > View Log to see a log output 
for your individual server. Computer IDs can be found by double-clicking a server in the console 
and looking at the ID value. This is very useful for tracking down DTK problems. Increase the 
log level if additional information is needed.

• Some models are not supported for certain operations. These issues can be found in the release 
notes or the Dell DTK release notes.

After upgrade my custom Dell jobs stopped working
Before Deployment Solution for Dell servers installs, it renames the existing Dell folder in the 
eXpress share to Dell_prev. This is to prevent any modifications you have made from being 
overwritten. In most cases, you need only change “Dell” to “Dell_prev” in your custom jobs to point 
to the new location.

Power control options no longer work for some of my 
servers

Most likely the IP address, user name, or password for the DRAC or BMC has changed since you 
first discovered it. Rediscover servers on the Configuration Utility Power Control tab to re-enable 
power control.

Setdell Not Found
If you receive an error indicating that setdell cannot be found, it is possible that DNS is not correctly 
resolving the address to your Deployment Share.
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To add a static IP entry to map the Deployment Share
1 In the Deployment Console click Tools > PXE Configuration.
2 Select the Dell WinPE or Linux boot image.
3 Click Edit, and then click Edit Boot Image.
4 Click << Edit (do not click Next) on the Edit Configuration step. The Wizard returns to step 1 of 

12. 
5 Click Next until you are on step 6 of 12, Network Drive Mappings.
6 Enable the Create an entry in the LMHosts file option.
7 Click Next, accepting the defaults, until the wizard completes.
8 Save your changes before closing the PXE Configuration Utility.

Which OEM extensions option should I select when using 
automation partitions?

When creating Boot Disk Creator configurations for use with automation partitions, we recommend 
selecting the <DELL> OEM extensions option. (note: This has changed since version 2.0. <default> 
was recommended in version 2.0). This option includes the Dell OEM extensions which let you run 
DTK tools from the Deployment Share in the automation environment.

The <DELL_DUP> OEM extensions option is for running Dell Update Packages (DUPs) in the 
Linux preboot environment.  In general, this option should not be used for other purposes as it may 
not have full functionality for the Deployment Solution agent.

How do I restore the jobs that were automatically generated 
after configuration?

1 In the Deployment Console, click Tools > Dell Tools > Job Builder. 
2 Click Restore default jobs.

I am getting stop errors (blue screens) during Windows 
scripted installations on some servers

This usually indicates that the job was not able to provide the necessary Windows mass storage 
drivers during the installation.

To correct this, use the Configuration Wizard to install the Windows drivers from the Dell Server 
Assistant (DSA) CD for the server model on which the error occurs.

1 In the Deployment Console, select Tools > Dell Tools > Configuration Wizard.
2 On the Select Models step, select the server models on which the error occurs. 
3 When promted, provide the DSA CD for the selected server models.
If this does not resolve the issue, you might need to obtain an updated driver from the Dell website. 
These can be added to the driver library utilized by the scripts by completing the following:

1 In the Deployment Console, select Tools > Dell Tools > Configuration Utility.
2 Select the OS Deployment tab.
3 In the Windows Drivers section in the lower portion of the Window, click Add.
4 In the Add driver from another source section, select an operating system, driver type (for 

example, mass storage), and then click Add from Other Source.
5 Browse to the txtsetup.oem file that was distributed with the downloaded driver.
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These new drivers are now available when the job is rescheduled.
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