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Chapter 1:
Introduction

Carbon Copy Solution integrates remote control functionality into the Altiris Infrastructure. This
provides effective management of remote computers from within the Altiris Resource Manager.

Specifically, Carbon Copy allows you to do the following:

* Browse and connect to devices from a Web page.

* Run Remote Control, File Transfer, Voice Chat, and Remote Printing utilities.

*  Manage the deployment and configuration of devices from a central location.

* Monitor events such as connection status, remote utility usage, and security warnings.
* Generate predefined Web reports or create customized reports.

* Receive e-mails or perform other notification events when certain conditions occur.

How Carbon Copy Works

Altiris Carbon Copy Solution is comprised of three distinct pieces:

* Carbon Copy Components (see “Carbon Copy Components” on page 5)
* Carbon Copy Solution Interfaces (see “Carbon Copy Solution Interfaces” on page 5)

» Carbon Copy Agent (see “Carbon Copy Agent” on page 6)

Carbon Copy Components

The Carbon Copy components provide functionality from the Altiris Console. These components
allow you to do the following:

* Deploy and configure the Carbon Copy Agent (see “Carbon Copy Agent Management” on
page 10).

* Open a window to connect to and remotely control a computer (see “Carbon Copy Solution
Utilities Overview” on page 15).

Carbon Copy Solution Interfaces

Carbon Copy Solution includes two Carbon Copy interfaces: The Altiris Console” Carbon Copy
Remote Control window and a Pocket PC Carbon Copy Console. Both of these interfaces allow you
to remotely control devices running the Carbon Copy Agent. You can connect to any Altiris Carbon
Copy product and to Compaq Carbon Copy products (versions 5.0 to 6.0).

The Altiris Console’s Carbon Copy Remote Control window will operate on any Win32 computer
with Microsoft Internet Explorer installed. When the Carbon Copy is used in the Altiris
Infrastructure, the Carbon Copy utilities are downloaded from the Notification Server to the local
computer. The Carbon Copy utilities will remain cached on the local computer. From the Altiris
Console’s Carbon Copy Remote Control window, you can launch Carbon Copy utilities including
Remote Control. File Transfer, Remote Clipboard, Voice Chat, and Remote Printing.
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Chapter 1: Introduction

The Pocket PC Carbon Copy Console will operate on handheld devices running Pocket PC 2000 or
2002. The Pocket PC Carbon Copy Console must be installed on the handheld device.

Carbon Copy Agent

To remotely control a device, the Altiris Agent and the Carbon Copy Agent must be installed on the
device. The Altiris Agent’s primary functions include communications, security, and event logging.

The Carbon Copy Agent is configured and rolled out to the remote computers using the Altiris

Console. For more information on installing the Carbon Copy Agent, see “Carbon Copy Agent
Management” on page 10.
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Chapter 2:
Carbon Copy Solution Installation and Configuration

This section provides information on Carbon Copy Solution requirements and installation
instructions.

Carbon Copy Solution Requirements

Notification Server

Notification Server Version 6.0 (or above)

Carbon Copy Solution requires Notification Server to be installed and configured.

Altiris Console

The Altiris Console can be used on a computer that runs Microsoft Internet Explorer 5.5 or higher.

Remotely Managed Computer

For a computer to be remotely managed using Carbon Copy Solution, it must meet the following
minimum requirements:

* Altiris Agent Version 6.0 or Notification Server Client Version 5.5 and later
* Intel 486 or higher
*  Microsoft Windows 98, Windows Me, Windows NT, Windows 2000, Windows XP, Windows

Server 2003
* 4 MB free hard disk space
* 64 MB RAM

*  Microsoft Internet Explorer 4.1 or higher

Carbon Copy Solution Handheld Console

Microsoft Pocket PC 2000 or 2002 (Windows CE 3.0)
Strong ARM processor

Microsoft Internet Explorer version 5.0 or later
ActiveSync 3.1 or higher

Installing Carbon Copy Solution

Before installing the Carbon Copy, please review the prerequisites information.

You must install Altiris suites and solutions from the Altiris Console running the Notification
Server. The following procedure assumes that you have already installed a Notification Server.
To install Carbon Copy Solution on the Notification Server

1 At the Notification Server computer, open the Altiris Console by clicking Start > All Programs >
Altiris > Altiris Console.

2 Click the Configuration tab.
3 In the left pane, click Configuration > Upgrade/Install Additional Solutions.
4 In the right pane, click the Available Solutions tab.
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Chapter 2: Carbon Copy Solution Installation and Configuration Carbon Copy Solution Role Management

5 Click the Solutions button.
6 Click the Altiris Carbon Copy Solution link.
7 Click Start.

Carbon Copy Solution Role Management

Properly configuring security is an important part of using Carbon Copy Solution. In most
environments, you will have multiple users that need to have various degrees of access to Carbon
Copy Solution. These users might be workers, managers, or administrators. Each type of user has
different access needs. Setting-up security properly will ensure that your network is secure while
permitting users to have the access they need. If security is setup properly, each user has exactly the
rights needed.

In Notification Server security, a role is a set of Notification Server privileges for a group or
individual. An individual is a Windows domain or local computer user. A group is a domain, local
computer, or Notification Server defined group of users. After you configure a role, you can add a
user to that role.

Role-based security lets you set privileges for accessing Altiris Console tabs; the creation of reports,
collections, and policies; the changing of security settings; the changing of incidents; and more.

We recommend that you add those that need access to Carbon Copy Console to roles and then set
the privileges for these roles accordingly. To assist you, there are several predefined roles that you
can use.

Predefined Security Roles

Several security roles are added to Notification Server. These roles simplify the process of granting
the appropriate rights to users. If the rights and permissions provided by these roles are adequate for
your needs, all you need to do is assign the appropriate users to each role. The privileges of each role
can also be modified if needed.

When Carbon Copy Solution is installed, the Carbon Copy Privileges section is added to the Role
Management page. The Carbon Copy Privileges section contains the following options:

* Create Carbon Copy Agent Settings
* Remotely Control with Carbon Copy
These options are enabled by default for the following roles:

¢ Altiris Administrators
¢ Altiris Level 1 Workers
¢ Altiris Level 2 Workers

¢  Altiris Supervisors

Viewing and Configuring Role-based Security

To view or configure role-based security
1 In the Altiris Console, click the Configuration tab.

2 Inthe treeview pane, click Configuration > Server Settings > Notification Server Settings > Security
Role Management.

3 In the content pane Roles section, select a security role.

Tip: You can clone an existing role and make modifications to the new role and leave the original
role intact.

4 In the Global privileges section, scroll to the Carbon Copy Privileges section and do the following:
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* To allow the role members to control remote computers running the Carbon Copy Agent,
check the Remotely Control with Carbon Copy box.

* To disallow the role members to control remote computers running the Carbon Copy Agent,
clear the Remotely Control with Carbon Copy box.

* To allow the role members to create or modify Carbon Copy Agent settings, check the Create
Carbon Copy Agent Settings box.

* To disallow the role members to create or modify Carbon Copy Agent settings, clear the
Create Carbon Copy Agent Settings box.

5 To add users to the role, click the Edit button on the toolbar.
6 Click the Apply button.

Important: You may need to change the role option settings for each of the roles.
For more information on configuring security, see Altiris Notification Server Help.

If a user has not been given access (based on the user account and role membership), they can not
configure the Carbon Copy Solution or remotely control computers using Carbon Copy.
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Chapter 3:

Carbon Copy Agent Management

To remotely control a computer, the remote computer must have the Altiris Agent and a Carbon
Copy Agent loaded. Carbon Copy Solution provides policies for configuring Carbon Copy Agents
and for rolling out the Carbon Copy Agents to collections of computers.

Modifying Carbon Copy Agent Configuration Policies

Configure the Carbon Copy Agent using the Carbon Copy Agent configuration policies. The
policies are enabled by default and should remain enabled for the settings to be in effect. Before
using Carbon Copy, you should review the configuration settings in each policy and make changes
as needed. After configuring the Carbon Copy Agent, you will use a Carbon Copy Agent rollout
policy to roll the configured agent to the computers in the selected collection.

To modify a Carbon Copy Agent Configuration policy

1 In the Altiris Console, click the Configuration tab.

2 In the left pane, select Configuration > Solution Settings > Incident Management > Carbon Copy >
Carbon Copy Agent Configuration > policy.

3 In the right pane, click the General tab, make the wanted changes, and click Apply.
Important: Make sure you enable the policy and apply the policy to a collection.
4 In the right pane, click the Authentication tab, make the wanted changes, and click Apply.

Important: Add an active group or profile to the Active group or profiles to use to authenticate to
the remote computers using the Carbon Copy Agent.

5 In the right pane, click the Advanced Settings tab, make the wanted changes, and click Apply.

Note: You can require a password to access areas in the Carbon Copy Agent interface using the
Advanced Settings tab.

Important: The Customize Agent Ini Settings field should only be used in conjunction with Altiris
Customer Support or Altiris Consulting to resolve unique Carbon Copy Agent configuration
issues.

Carbon Copy Agent Configuration Settings

The Carbon Copy Agent Configuration page has a General tab, Authentication tab, and Advanced
Settings tab.

General Tab

Enabled
Select the Enabled check box to enable the policy.
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Applies to Collection

Click the link to open the Collection Selector, select the collection or collections to associate to the
policy, and click OK.

Connection Settings

When the Notify user during connection attempt is selected, a message is sent to the computer
indicating that an attempt to connect to the computer is in progress.

When the Notify on disconnect is selected, a message is sent to the computer when a remote user
disconnects.

When Require user to approve connection is set to Always or Only when logged in (NT/2000/XP/2003),
the user at the computer will have to respond to the dialog box to allow the connection.

The value in the Maximum number of connections field is the maximum number of connections to the
computer allowed. The default is 256.

When Enable data encryption is selected, the computers communicate using encrypted data.

Remote Control Options

When Enable synchronous remote control sessions is selected, the computer will run in Remote
Control’s synchronous mode. When cleared, it will run in Remote Control’s asynchronous mode.
The computer running the Carbon Copy Agent must be rebooted for this change to apply.

Authentication Tab

Agent Authentication Settings

When Authentic connections is selected, Carbon Copy Solution requires login credentials
(authentication through usernames and passwords) to allow access to the remote computer. Logins
are dependent on the operating system of the remote computer:

*  For Windows NT/2000/XP/2003 Server, Native NT is selected by default and the local
Administrators group is allowed access. When Native NT is selected, the local Administrators
group is created each time Carbon Copy is started. To disallow access, you must disallow
connections for this group.

*  For Windows 98/Me, a Carbon Copy profile is used. The username is “Administrator” and the
default password is “altiris”.

The Login type is used to select the type of login security to use. The choices are Active Directory,
Native NT, and Carbon Copy

Carbon Copy profile passwords must have at least the numbers of characters in the Minimum Carbon
Copy profile password length field. The value can be changed.

The Active group or profiles field lists the groups or profiles that can authenticate to the remote
computer.

To add a group or profile, enter the information in the User name, Password, and Confirm password
fields and click Add

Agent Login Settings

When Enable lockout security is set to Never, the computer will not disable Carbon Copy logins.

When Enable lockout security is set to All systems, the computer will disable Carbon Copy logins for
all systems when the number of attempts in the Maximum number of login attempts field is reached or
the number of seconds in the Timeout connection attempts after number seconds is exceeded.

When Enable lockout security is set to Offending System only, the computer will disable Carbon Copy
logins from the offending system when the number of attempts in the Maximum number of login
attempts ficld is reached or the number of seconds in the Timeout connection attempts after number
seconds is exceeded.
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Advanced Settings Tab

You can require a password to access areas in the Carbon Copy Agent interface by entering a
password and confirming it, then selecting the interface areas to password protect.

Important: The Customize Agent Ini Settings ficld should only be used in conjunction with Altiris
Customer Support or Altiris Consulting to resolve unique Carbon Copy Agent configuration issues.

Modifying Carbon Copy Agent Packages and Rollout
Policies

Whenever you make changes to a Carbon Copy agent configuration policy, you need to roll out those
changes. The Carbon Copy agent rollout policies are used to roll out the agent configuration
changes. By default, these policies are not enabled.

Modifying the Carbon Copy Agent Package
Settings

To modify agent package settings
1 In the Altiris Console, click the Configuration tab.

2 In the left pane, select Configuration > Solution Settings > Incident Management > Carbon Copy >
Carbon Copy Agent Rollout > Carbon Copy Agent Package.

3 In the right pane, click the Package tab and make the wanted changes.
4 In the right pane, click the Programs tab and make the wanted changes.

Note: To modify the command line settings, use InstallShield parameters. An example of the
Command line is: CC-Solution-Agent.exe /S /V/gn.

5 In the right pane, click the Advanced tab and make the wanted changes.
6 Click Apply.

Modifying Carbon Copy Agent Rollout Policies

Carbon Copy Solution includes three rollout policies: No Reboot - Carbon Copy Agent Install, No
Reboot - Carbon Copy Agent Upgrade, and Reboot - Carbon Copy Agent Install. Only one of these
policies should be enabled for a particular collection.

When the Reboot - Carbon Copy Agent Install policy is enabled and the Carbon Copy Agent has been
rolled out, the targeted computer will automatically reboot. This step is necessary for the computer
to be remotely controlled in both synchronous and asynchronous remote control modes. If you do
not want the targeted computer to automatically reboot, enable the No Reboot - Carbon Copy Agent
Install or No Reboot - Carbon Copy Agent Upgrade policy. These policies will only rollout the Carbon
Copy Agent. On Windows NT4/2000/XP computers, the Carbon Copy Agent will accept
connections and remote control will run in asynchronous mode only. On Windows 98/Me
computers, a virtual device driver must be installed for remote control to function. Therefore, the No
Reboot - Carbon Copy Agent Install or No Reboot - Carbon Copy Agent Upgrade policy still requires a
computer reboot to run remote control on computers running these operating systems. After the
computer is rebooted, you will be able to toggle between synchronous and asynchronous remote
control modes.

The rollout policies are scheduled to rollout the Carbon Copy Agent as soon as possible after a

rollout policy is enabled. You can change the Carbon Copy Agent rollout settings to schedule the
job at off-peak times.
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To change agent rollout settings
1 In the Altiris Console, click the Configuration tab.

2 In the left pane, select Configuration > Solution Settings > Incident Management > Carbon Copy >
Carbon Copy Agent Rollout > policy

3 In the right pane,
a To enable the policy, select the Enable check box.

b To change the collection, click the collection link next to Applies to collections and use the
Collection Selector.

¢ To change the schedule, click the Schedule check box, click the link next to the schedule
check box and use the Schedule Editor.

Important: The default schedule setting is set to “Run once ASAP” (as soon as possible).
Even though the Carbon Copy Agent Rollout policies have the “Run once ASAP” selected
by default, a policy will not run until it is enabled.

d Click Apply.

4 Verify that the other rollout policies are not enabled for the selected collection or collections.

Uninstalling Carbon Copy Agents

Carbon Copy Solution includes a default uninstall policy: No Reboot - Carbon Copy Agent Uninstall.
Only one of these policies should be enabled for a particular collection.

You can uninstall a limited number of agents or the entire collection of installed agents.

If you want to uninstall the Carbon Copy Agent from a limited number of computers, you must first
filter out the computers that the Carbon Copy Agent will be uninstalled from the NS Agents Requiring
Carbon Copy Upgrade collection. This will prevent a new installation of Carbon Copy at the next
scheduled deployment. You must then create a custom collection containing the computers to
uninstall the Carbon Copy Agent from. For information about modifying collections, see the Altiris
Notification Server Help.

If you want to uninstall all installed Carbon Copy agents, you should disable all Carbon Copy agent
deployment policies. This will prevent a new installation at the next scheduled deployment.

To uninstall Carbon Copy Solution Agents

1 In the Altiris Console, click the Configuration tab.

2 In the left pane, select Configuration > Solution Settings > Incident Management > Carbon Copy >
Carbon Copy Agent Uninstall > No Reboot - Carbon Copy Agent Uninstall.

3 In the right pane, make the wanted changes.
a To enable the policy, select the Enable check box.

b To choose the collections, click the link that follows Applies to collections and select the
collection or system using the Collection Selector.

Note: If you are uninstalling the Carbon Copy Agent from a limited number of computers,
you should also change the default schedule to a different setting from Carbon Copy
Configuration Rollout policy.

4  Click Apply.

Accessing the Carbon Copy Agent Interface when it is not
in the System Icon Tray

When the Carbon Copy icon is hidden (not in the system icon tray), you can display the icon. The
command options shown below allows an administrator to temporarily display the icon to access the
interface and then hide the icon at the end of a session.
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To show the icon

1

At the local computer or using Remote Control for a remote computer, click Start > Run and type
CMD.

Go to the folder where client.exe is located. The default path is:
c:\program files\altiris\carbon copy\
Type: client -show and press RETURN.

The Carbon Copy icon is displayed in the system icon tray.

To hide the icon

1

At the local computer or using Remote Control for a remote computer, click Start > Run and type
CMD.

Go to the folder where client.exe is located. The default path is:

c:\program files\altiris\carbon copy\

Type: client -hide and press RETURN.

The Carbon Copy icon is removed from the system icon tray.
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Chapter 4:
Carbon Copy Solution Utilities Overview

Carbon Copy Solution includes a number of utilities to remotely control computers that have the
Carbon Copy Agent installed. Using the Remotely Control with Carbon Copy page you can connect
to and control multiple remote computers. If you click the Advanced button, additional utilities are
available in the toolbar, but you can only connect to and remotely control one computer at a time.

Remotely Control with Carbon Copy

1 Do one of the following:

* Inthe Altiris Console, click the Tasks tab and in the left pane, click Tools > Remotely Control
with Carbon Copy.

* Inacollection in the Altiris Console, right-click on the computer and click Remotely Control
with Carbon Copy.

* In Resource Manager, click the Tasks tab and click the Remotely Control with Carbon Copy
link.

* Ifyou have a Helpdesk incident that is associated with an asset, click the Carbon Copy icon.

The Remotely Control with Carbon Copy window opens. The utilities and configuration changes
will remain on the local computer until the window is purged from its temporary location.

2 Enter either the workstation name or the IP address in the Computer Name ficld. You can use the
Click to select link to find the computer name.

3 Click the Connect button.
The information in the Status field will change as the connection is initiated.
4 Iflogin credentials are required, enter the credentials.

Important: If Carbon Copy Solution is using Active Directory Security or Native NT Security,
include the domain or local computer workstation name with the user name. For example:
DOMAIN\USER _NAME or COMPUTER NAME\USER _NAME.

By default, an RCGuest window is opened to the remote computer. Using the Remotely Control
with Carbon Copy utility, you can open multiple RCGuest windows to multiple remote computers.

5 When the RCGuest window opens, you can use the window to control the remote computer.

6 When you are done remotely controlling the remote computer, exit the window by clicking the
Exit from remote system button in the upper-right corner of the window.
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Remotely Control with Carbon Copy’s Advanced Ultilities

Carbon Copy Solution includes a number of utilities to remotely control computers that have the
Carbon Copy Agent installed. These Carbon Copy utilities are accessed by clicking the Advanced
button on the Altiris Console’s Remotely Control with Carbon Copy page. When the page refreshes,
additional buttons are added on the toolbar a the top of the window.

Remotely Control with Carbon Copy Window Toolbar Buttons and Descriptions

Button Utility Description

Connect Connects to the computer entered in the Name field provided the
computer has the Carbon Copy Agent installed and running.

Disconnect Disconnects from the computer entered in the Name field.
)
Remote Control Allows you to take full operational control of a remote computer,
T including the ability to launch applications or change system
settings. See “Remote Control” on page 17.
File Transfer Allows you to copy, synchronize, create, and delete files or
L_"*_] directories on a remote computer. See “File Transfer” on page 17.

Remote Clipboard Allows you to cut or copy text and graphics from a local
;J application and paste the data on the remote computer or vice
versa. See “Remote Clipboard” on page 19.

Voice Chat Allows you to speak or exchange text messages with users on a
gﬁ remote computer while running Remote Control, File Transfer, or
any other utility. See “Voice Chat” on page 17.

Remote Printing  Allows you to locally print documents from a remote computer.
@ See “Remote Printing” on page 18.

Connecting to a Remote Computer

Carbon Copy Solution allows you to make a connection to remote computer that has the Carbon
Copy Agent installed. When connected to a remote computer, you can use the Remote Control, File
Transfer, Remote Clipboard, Voice Chat, and Remote Printing utilities with the remote computer.
To connect to a remote computer

1 Do one of the following:

* In the Altiris Console, click the Tasks tab and in the left pane, click Tools > Remotely Control
with Carbon Copy.

* Inacollection in the Altiris Console, right-click on the computer and click Remotely Control
with Carbon Copy.

* In Resource Manager, click the Tasks tab and click the Remotely Control with Carbon Copy
link.

» Ifyou have a Helpdesk incident that is associated with an asset, click the Carbon Copy icon.

The Remotely Control with Carbon Copy window opens. The utilities and configuration changes
will remain on the local computer until the window is purged from its temporary location.

2 Click the Advanced button bottom of the page.

3 Enter either the workstation name or the IP address in the Computer Name ficld. You can use the
Click to select link to find the computer name.

4 Click the Connect icon in the toolbar.
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The information in the Status field will change as the connection is initiated.
5 Iflogin credentials are required, enter the credentials.

Important: If Carbon Copy Solution is using Active Directory Security or Native NT Security,
include the domain or local computer workstation name with the user name. For example:
DOMAIN\USER_NAME or COMPUTER _NAME\USER_NAME.

By default, a Remote Control window for the remote computer is opened.

Note: When the computers are connected, you can use the Remote Control, File Transfer, Remote
Clipboard, Voice Chat, and Remote Printing utilities with the remote computer by clicking on the
corresponding icon in the Remotely Control with Carbon Copy window.

Remote Control

The Remote Control utility lets the local computer take full operational control of a remote computer
that has the Carbon Copy Agent installed, including the ability to launch applications or change
system settings. When a connection is made with a remote computer, a Remote Control window
appears (by default) which displays the remote computer’s desktop. Within the window, all
keyboard and mouse functions are sent to the remote computer.

Starting Remote Control from the Altiris Console

To manually start a Remote Control session

1 Open a connection to the remote computer (see “Connecting to a Remote Computer” on
page 16).

2 In the Remotely Control with Carbon Copy window, click the Remote Control icon.
The Remote Control window will appear. You can now control the remote computer. You can

also change the view of the remote desktop or send the CTRL+ALT+DEL command using the
Remote Control toolbar.

File Transfer

The File Transfer utility copies, synchronizes, creates and deletes files or folders on the local
computer and a remote computer. File Transfer uses a split window method similar to the Windows
Explorer view, and uses the same file selection and movement techniques. Files can be dragged and
dropped into their new location.

File Transfer has two methods of transfer: Copy and Synchronize. Copy takes selected files and
moves them to specific locations. Synchronize compares two directories or files, determines the
latest versions, and then copies only the necessary portions so that the latest files reside on both
computers.

Starting File Transfer from the Altiris Console

To start a File Transfer session

1 Open a connection to the remote computer (see “Connecting to a Remote Computer” on
page 16).
2 In the Remotely Control with Carbon Copy window, click the File Transfer icon.

The File Transfer window will appear. You can now copy or synchronize folders and files
between the computers.

Voice Chat

The Voice Chat feature allows the user of the Altiris Console’s Remotely Control with Carbon Copy
window to speak with remote computer users while they run Remote Control, File Transfer, or any
other utility. Any number of Carbon Copy users, connected to a central computer, can speak with
one another.

Altiris Carbon Copy Solution Product Guide 17



Chapter 4: Carbon Copy Solution Utilities Overview

You must have a sound card, speakers, and a microphone on each computer. If a computer is not
properly equipped, the Voice Chat feature defaults to Text Chat.

The Text Chat feature allows the local computer to exchange typed messages with the remote
computer. The Text Chat fields appear at the bottom of the Voice Chat window.

You can copy text chat messages to the Windows Clipboard and paste it into other applications, or
copy text from an application and paste it into the text chat window.

Starting Voice Chat from the Altiris Console

To start a chat Session

1 Open a connection to the remote computer (see “Connecting to a Remote Computer” on
page 16).

2 In the Remotely Control with Carbon Copy window, click the Voice Chat icon.

On the local computer, the Voice Chat dialog box will appear with the message “Waiting to join
REMOTE COMPUTER’s conference. On the remote computer, an audible ring is played and the
Voice Chat dialog box appears with the message “COMPUTER wishes to join the conference.”

When the OK button on the remote computer’s Voice Chat dialog box is clicked, the Carbon Copy
Voice Chat utility appears on both computers.

If both computers have sound cards, the Voice Chat window will appear on both computers. At
the bottom of the Voice Chat window, you can type a message and press ENTER to send the text
message.

If either computer does not have a sound card, a Text Chat window will appear on both
computers. Type your message in the My Computer section of the windows. The message
automatically appears on the remote computer and the remote computer’s message will
automatically appear in the other section of the window.

Note: You can type any printable ASCII character, plus CTRL+G (beep) and BACKSPACE.

Remote Printing

Computers running the Altiris Console, the Carbon Copy Console, or the Carbon Copy Agent can
be set up to use Remote Printing. The remote printing feature allows users at connected computers
to print documents on the remote computer.

For remote printing to work, Remote Printing must be running and the source computer (where the
file is that you want to print) must have a printer defined with properties that use the
Carbon_Copy_Printer port and the same printer driver as the destination computer’s default printer.

For example, if the destination printer is an HP LaserJet 4, then the source computer should have a
printer definition configured to use the Carbon Copy Printer port and the HP LaserJet 4 printer
driver. If the destination computer’s default printer is changed, the source computer’s printer
definition must be reconfigured to use the same printer driver as the destination computer’s default
printer driver.

Remote Printing works only from Windows applications. It is not possible to print remotely from a
DOS application.

Configuring Remote Printing

Before you can use Remote Printing, you need to configure the source computer (where the file is
that you want to print) to print to a local printer that uses the Carbon_Copy_Printer port and has the
same drivers as the destination computer’s default printer.

To configure remote printing on the source computer

1 From the Windows start menu, click Start > Settings > Printers.

2 Double click the Add Printer icon in the Windows Printers folder.

3 Select Local Printer or My Computer. Click Next.
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4 The following steps may appear in reverse order depending on the computer’s operating system:
a Select the Carbon Copy Printer Port. Click Next.
b Select the destination computer’s printer manufacturer and model. Click Next.
¢ Type in a printer name. For example, HP LaserJet via Carbon Copy. Click Next.

d For Windows NT/2000, you will be prompted to share the printer. Click Not Shared and then
click Next.

5 Follow the remaining steps to install the printer.

Notes

* The source computer’s default printer does not have to be set to remote printer definition.

* Bidirectional support must be disabled. To verify, right click the remote printer’s icon and select
Properties. For Windows 95/98/Me, select the Details tab, click Spool Settings, and verify that
bidirectional printing is not selected. For Windows N'T/2000, select the Ports tab and verify that
bidirectional support is not enabled.

Starting Remote Printing from the Altiris Console

To start remote printing on the Altiris console

1 Open a connection to the remote computer (see “Connecting to a Remote Computer” on
page 16).

2 Click the Remote Printing icon. Remote Printing is now enabled.

You can now print documents from the remote computer. The Carbon Copy Solution will
automatically print to the remote computer’s remote printer.

Remote Clipboard

The Remote Clipboard feature allows connected computers to share a common clipboard. Text and
graphics can be cut or copied from an application on the console and pasted into a file on the remote
computer or vice versa.

The Remote Clipboard supports the following formats: Text (ASCII), OEM Text, DIB Bitmap,
Bitmap (.BMP), Palette.

Starting Remote Clipboard from the Altiris Console

To start Remote Clipboard

1 Open a connection to the remote computer (see “Connecting to a Remote Computer” on
page 16).

2 Click the Remote Clipboard icon. Remote Clipboard is now enabled.

On the local computer or remote computer, items cut or copied will be placed on the Remote
Clipboard and made available for pasting on either computer.
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Altiris’ Handheld Console provides remote control and text chat capabilities from a Pocket PC
device to systems running a Carbon Copy Agent or Carbon Copy Console.

The Handheld Console is integrated with Altiris’ Alert Manager and Helpdesk Solution. Workers
can view a work item and launch remote control in the same context as the desktop functionality.

Installing the Handheld Console on the Handheld Device

The Altiris Handheld Console must be physically installed on the Pocket PC device. When Carbon
Copy is launched from an Altiris Handheld Console containing a Carbon Copy link, such as the Alert
Manager Worker Console, a web page containing a download link will appear.

To handle installation, integration features include a link (http://Notification _Server/Altiris/
carboncopy/runcchh.asp or http://Notification_Server/Altiris/carboncopy/
runcchh.asp?FDQN={Client_to Control} to automatically download the handheld console.

Note: The user does not have to specify the FQDN parameter. It is only used for auto-connecting.

Creating Connections

You can create both Network (TCP/IP) and Modem (TAPI) connections using the Create New
Connection icon. Each connection you create contains information about the remote system, such as
the IP address, telephone number, or login information.

When created, you can manage connections by renaming, deleting, or changing connection
properties, and you can change the way connection icons are displayed.

Creating Network Connections

To create a new Network Connection

1 Tap on the Create New Connection icon.

2 Enter a name for the connection icon. Select Networking (TCP/IP) as the connection type.
3 Tap Configure Options.
4

Select the General Connection Info tab, and enter the workstation name or IP address of the remote
system.

(3]

Select a networking connection.
6 Select the Login tab.

7 If the remote system has security enabled, enter the login name and password. The password
appears as asterisks. You must retype the password in the Confirm Password box.

8 When you are done setting up the connection icon, tap OK.

A new connection icon appears in the Carbon Copy window.
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Creating Modem Connections

To create a Modem Connection
1 Tap on the Create New Connection icon.
2 Enter a name for the connection icon.

Use a name that will help you identify the entry, such as the workstation name or its principal
user.

3 Select Modem (TAPI) as the connection type.
4 Tap Configure Options.

5 On the General Connection Info tab, select the type of modem you are using to make the
connection.

To see a list of available devices, tap on the arrow by the first connection device.
6 Enter the Area code, Telephone number, and Country code of the remote system.
The area and country code are optional.
7 Select the Login tab.

8 If the remote system has security enabled, enter the login name and password. The password
appears as asterisks. You must retype the password in the Confirm Password field.

9 When you are done setting up the connection icon, tap OK.

The connection icon appears in the Carbon Copy window.

Making a Connection

To make a connection

You may only establish one connection at a time.

* Highlight a connection icon and tap Connections > Connect.

The Carbon Copy connection begins. When connected, Remote Control is started by default.

Closing a Connection

To close a connection

You may only establish one connection at a time.

* Tap Connections > Disconnect.

Managing a Connection

To manage a connection

You can rename, delete, or change the properties of a connection icon.

* Highlight a connection icon and choose the appropriate action from the Connections menu.

Launching from Altiris Consoles

Altiris Carbon Copy Solution Product Guide

Carbon Copy may be launched from any Altiris Handheld Console that contains a Carbon Copy link,
such as the Helpdesk Worker Console. To launch Carbon Copy and make a connection, simply tap
on the Carbon Copy link.
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When a connection is made from an Altiris Console, a new icon will appear in the connection
window. The icon is named _eXpressConnection. Its properties are automatically updated based on
the machine name supplied from the Altiris Console, and the login properties supplied from eXpress
Login option.

The eXpress Login option allows you set login information that will always be used when making
eXpress connections. This will simplify the connection process by supplying a predefined username
and password, similar to the login option associated with user-created connection icons.

eXpressConnection Icon

The _eXpressConnection icon may be treated as any other connection icon. Y ou may rename, delete,
or modify the icon. If you set an eXpress login, you do not have to modify the Login properties
because the information is obtained from the eXpress Login option.

eXpress Login Option

If you have an administrative account that allows access to all computers, you can enter your login
information in the eXpress Login dialog box. Whenever you connect from an eXpress Console, these
settings will automatically be used, and the login prompt will be bypassed.
To modify the login properties
1 Tap on Utilities > eXpress Login tab .
2 Enter the login name and password.
The password appears as asterisks.
3 Retype the password in the Confirm Password field.
4 When you are done making changes, tap OK.

Remote Control

The Remote Control feature lets you take full operational control of a remote computer, including
the ability to launch applications or change system settings. When started, a remote control window
that displays the remote system’s desktop will appear. Within the window, any stylus or keyboard
entries are sent to the remote computer as mouse and keyboard functions.

Starting a Remote Control Session

To start a Remote Control session
*  When connected, tap Utilities > Remote Control.

A remote control window displaying the remote system’s desktop will appear.

Stopping a Remote Control Session

To stop a Remote Control session
* Tap Connections > Exit from the Remote Control window.

Note: The connection remains active. You can start a new session by tapping Utilities > Remote
Control.
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Chat

Stopping a Remote Control Session and
Disconnecting

To stop the Remote Control session and disconnect

* Tap Connections > Disconnect.

Logging onto a Remote System

To log on to a remote system

» Ifyou are making a connection to a remote system running Windows NT, Windows 2000, or
Windows XP, and have not yet logged on, tap View > Send CTRL+ALT+DEL. The logon prompt
will appear.

Using View Options

View menu options allow you to enable or disable scroll bars or to change the focus area on the
remote desktop. When changing the focus area, options include upper left, lower left, center, upper
right and lower right.

Using Tools Options

Tool menu options allow you to send various commands to the remote system. You can send
Ctrl+Alt+Del, reboot the remote system, or launch predefined or custom programs. Predefined
programs include Task Manager, Windows Explorer, and the Windows command prompt. You can
create, edit and delete custom programs to launch by tapping Tools > Manage Custom Programs.

The Chat feature allows you to exchange typed messages with a remote user.

The Pocket PC user always initiates a chat session. When you initiate a session, the remote user sees
a chat request. If the remote user accepts the request, chat begins. If the remote user denies the
request, chat is canceled.

When the remote user accepts, a Chat window appears on both systems. Text you type appears in
the top section of the window, and text the remote user types will appear in the bottom section. The
cursor in your local Chat window indicates where the next typed character will appear.

Starting and Stopping Chat

To start a Chat session

1 When connected, tap Utilities > Chat.

2 A dialog box appears telling you that you are requesting to chat with the remote system. If the
remote user chooses OK, chat begins. If the remote user chooses Cancel, your request to chat is
denied.

To stop the Chat session

*  From the Chat window, tap File > Exit .

The connection remains active. You can start a new session by tapping Utilities > Chat.

To stop the Chat session and disconnect

* From the Chat window, tap Connections > Disconnect.
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Console Options

You can customize the Handheld Console by setting configuration options that optimize
performance and streamline usability. Brief descriptions of general options are listed below. For
more information, refer to the Carbon Copy Handheld Console help.

Remote Control Options

Remote Control options contain parameters that define the look and feel of the remote control
session..

Options Descriptions

Show scroll bars  Select to show scroll bars. You can use scroll bars to quickly
move around the desktop.

Track blinking Select to follow the movement of a text cursor. Available when
cursors an application has a blinking cursor, such as Microsoft Word.

Display all text as  Displays all text as black on a white background. This may make
black on white text easier to read since it is displayed at a higher contrast.

Remote Computer Desktop Options

Desktop options contain parameters that improve remote control performance by making temporary
modifications on the remote computer.

Options Descriptions

Disable font Select this option to display fonts at a faster rate. When selected,

smoothing some fonts may appear jagged.

Disable desktop Select this option to disable the remote computer’s wallpaper

wallpaper setting. When you exit remote control, the wallpaper is turned
back on.

Ignore large Select this option to not display large bitmaps, such as splash

bitmaps screens.

Startup Options

Connection options allow you to select which Carbon Copy utility starts automatically when you
make a connection. You can select Remote Control, Chat, or None.
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