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Chapter 1
Overview

The Altiris® Connector Pack� for IBM Director is an add-on to Altiris® Connector 
Solution� that allows organizations to extend their investment in the IBM Director 
platform with inventory data from Altiris� award winning Notification Server repository. 

The Connector Pack for IBM Director leverages Connector Solution components to 
integrate the Altiris Infrastructure with IBM Director in three ways:

! Data Integration

Data integration is a basic import that consists of a user interface in which users 
select an Altiris computer that corresponds to an IBM Director computer, provides 
required connection details and security credentials, and optionally sets a schedule 
for a recurring data import. Subsequent to configuration, the basic import creates a 
linked server between the Altiris Infrastructure database and the IBM Director 
database, and proceeds to import basic identifying information for resources from 
the IBM Director database into the Altiris Infrastructure database on the configured 
schedule. Reports provide a set of reusable details for creating the linked server and 
importing basic identifying information.

! Event Integration

Event integration provides a user interface where users select an Altiris computer 
resource corresponding to an IBM Director computer, and enable or disable SNMP 
trap events targeted at the IBM Director computer. MIBs that enable IBM Director to 
interpret received SNMP trap events are included in the Connector Pack Agent for 
IBM Director.

! UI Integration

A pre-defined set of UI integrations between the Altiris Infrastructure and IBM 
Director are included in the Connector Pack Agent for IBM Director.

The Connector Pack for IBM Director creates the Connector Pack Agent for IBM Director 
dynamically on demand for manual download to the IBM Director computer, or for 
automated software delivery to the IBM Director computer.

Quick Links

! Installing the Connector Pack for IBM Director (page 5)

! Getting Started with the Connector Pack for IBM Director (page 7)

! Using the Connector Pack for IBM Director (page 13)



 

Chapter 2
Installation

This section tells you how to install the Altiris Connector Pack for IBM Director onto the 
Notification Server.

! Installing the Connector Pack for IBM Director (page 5)

! Uninstalling the Connector Pack for IBM Director (page 6)

! Registration (page 6)

Installing the Connector Pack for IBM Director
This section explains how to install the Connector Pack for IBM Director. See 
Prerequisites (page 5) before you install or upgrade.

Quick Link

! Installing (page 5)

Prerequisites
! Notification Server 6.0 SP3 must be installed on the computer you are installing the 

Connector Pack for IBM Director on. For more information, see Altiris Notification 
Server Help.

! The Notification Server computer with this Connector Pack installed must have 
network access to an IBM Director computer (version 5.10).

! Altiris Connector Solution 6.1 must be installed on Notification Server. If Connector 
Solution 6.1 is not installed, the Connector Pack installation installs it for you.

Installing

To Install the Connector Pack for IBM Director

1. Open the Altiris Console.

" Select Start > Programs > Altiris > Altiris Console.

2. Click the Configuration tab.

3. In the left pane, click Upgrade/Install Additional Solutions.

4. In the right pane, click the Available Solutions tab.

5. Click the Segments sub-tab.

6. Expand either the Connectors or the Partner Solutions list.

7. Click Altiris Connector Pack for IBM Director.

8. Click Start.
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Uninstalling the Connector Pack for IBM Director

To uninstall the Connector Pack for IBM Director

1. Open the Altiris Console.

" Select Start > Programs > Altiris > Altiris Console.

2. Click the Configuration tab.

3. In the left pane, click Upgrade/Install Additional Solutions.

4. In the right pane, click the Currently Installed tab.

5. Click the Remove button next to Altiris Connector Pack for IBM Director.

To uninstall the Altiris Connector Agent from the IBM Director 
computer

1. Remove the Altiris Connector Agent by running Add/Remove Programs in the 
Control Panel.

2. Manually delete the Altiris MIBs from the IBM Director computer.

3. From the Altiris console, delete the IBM Director computer from the IBM Director 
Computers collection.

Registration
Each Altiris product comes with a 7-day trial license that is installed by default. You can 
register and obtain a 30-day evaluation license through our Web site at www.altiris.com 
or purchase a full product license.

To view your current license, open the Altiris Console, click the Configuration tab, and 
select Licensing.

For more information, see �Licensing Altiris Software� in the Altiris Getting Started Guide 
on the product CD or on our Web site at www.altiris.com/support/documentation.
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Chapter 3
Getting Started with the Connector Pack for IBM 
Director

The Getting Started tasks guide you through the basic setup, configuration, and use of 
the Connector Pack. This section assumes that you have successfully installed the 
Connector Pack for IBM Director on your Notification Server and have IBM Director set 
up on a separate computer.

Getting started tasks

! Adding Computers to the IBM Director Computer�s Collection (page 7)

! Performing Event Integration (page 8)

! Installing the Altiris Connector Pack Agent for IBM Director (page 8)

! Viewing UI Integration and Compile Altiris MIBs (page 9)

! Performing Data Integration (page 10)

! Running a Report on Data from IBM Director (page 11)

Prerequisites for Getting Started tasks

! Notification Server 6.0 SP3

! Connector Pack 6.0 for IBM Director

! Computer with IBM Director 5.10 set up and running

Exercise scenario

You have been asked to perform event and UI integration from Notification Server to 
IBM Director. After the event integration is received, you need to set up and run data 
integration from IBM Director to Notification Server. Finally, you need to run a report 
giving you the inventory of computers managed by IBM Director.

Adding Computers to the IBM Director Computer�s Collection
Before using the Connector Pack, you must add one or more IBM Director computers to 
the IBM Director computer�s collection.

To add a computer to the collection

1. From the Altiris Console, select Configuration > Solutions Settings > 
Connectors > IBM Director > IBM Director Computers.

2. Click the Edit collection icon.

3. In the Inclusions section, click the link next to the pencil icon.

4. Click the Add a resource icon.

5. Select the search criteria and click Find.

6. Select the resource you want added to the collection.
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7. Click OK.

8. Click OK.

9. Click Apply.

Performing Event Integration
In order to have event integration, you must select the SNMP listeners (events) for the 
IBM Director Computers collection.

If you have not done so, you should now add SNMP listeners to your SNMP destination 
collections. For information on adding SNMP listeners and setting up SNMP automated 
actions, see the Connector Solution Product Guide.

After you have added SNMP listeners to your SNMP destination collections, you can set 
up event integration.

To set up event integration

1. From the Altiris Console, click the Configuration tab.

2. In the left pane, select Configuration > Solutions Settings > Connectors > 
IBM Director > Event Integration.

3. In the Select an SNMP Destination (Collection) list, select the IBM Director 
Computers collection.

4. For each SNMP listener in the list that appears, set up which SNMP automated 
actions you want to be enabled or disabled.

5. Click Apply.

Installing the Altiris Connector Pack Agent for IBM Director
The Altiris Connector Pack Agent for IBM Director communicates with IBM Director. The 
agent installs files and folders on your IBM Director computer that are needed for 
performing event and UI integration with IBM Director. It must be installed on a 
Windows computer and must be installed before the Connector Pack will work. However, 
it cannot be installed until after you install the Connector Pack. 

To install the Connector Pack Agent for IBM Director

1. From the Altiris Console, click the Configuration tab.

2. In the left pane, select Configuration > Solutions Settings > Connectors > 
IBM Director > Agent Configuration.

3. Download the Connector Pack Agent for IBM Director executable by clicking the 
Download the Agent button in the Agent Configuration page and installing the 
executable to a location accessible by the IBM Director computer. 

4. Install the Connect Pack Agent on the IBM Director computer by running the 
executable. The executable is installed in the Program 
Files\Altiris\ConnectIBMDirectorAgent folder.

Note
To verify that the Connector Pack Agent has installed, go to Add/Remove Programs and 
verify that there is a program called Altiris Connector for IBM Director Agent.
Connector Pack for IBM Director Product Guide 8



 

Viewing UI Integration and Compile Altiris MIBs

The Connector Pack Agent downloads Altiris MIBs and UI components to the IBM 
Director computer. After the Connector Pack Agent installs, you can view the Altiris UI 
components. However, you need to compile the Altiris MIBs before event integration is 
completed.

To view the Altiris UI components on IBM Director

1. The Altiris UI components can be accessed from the IBM Director Console in the 
following areas:

" The Tasks pane in the View tab. 

Note
Drag a computer resource to the Altiris Resource Manager link to open Resource 
Manager with that resource�s information.

" Right-click on a resource object and select Altiris > Altiris Resource 
Manager. (This only applies to the Altiris Resource Manager link.)

" Click Tasks > Altiris.

" On the Configuration page of the Toolbar, you can add an Altiris button.

To compile the Altiris MIBs

1. From the IBM Director Console, select Tasks > SNMP Browser > Manage MIBs.

2. Select File > Select MIB to compile.

3. Select ALTIRIS-CUSTOM-MIB-6-0.mib.

4. Click OK.

5. Select and compile ALTIRIS-MIB-6-0.mib.

6. Select and compile any other Altiris MIBs.

Altiris UI Components

Component Description

Altiris Console Opens the Altiris Console.

Altiris Reports Console Opens the Altiris Console to the Reports 
tab.

Altiris Resource Manager Opens Resource Manager in the context 
of a single computer. This only opens if a 
computer resource is selected or dragged 
to the Altiris Resource Manager link.

Altiris Web Site Opens the Altiris Web site.

Data Integration Configuration Opens the Altiris Console with the Basic 
Data Import page displayed.

Deployment Console Opens the Altiris Console to the 
Deployment tab.
Connector Pack for IBM Director Product Guide 9



 

7. Select File > Select MIB to load and verify that the compiled Altiris MIBs are 

loaded.

Performing Data Integration
There are two types of data integration: setting up a database link and importing 
computer resources.

The most common form of data integration is to link the Notification Database with the 
IBM Director database. When the link is established, you can run reports that access 
data from both databases. In this case, the IBM Director database becomes an 
extension of the Notification Database. 

At this time, SQL servers are supported. However, you should be able to establish a link 
to most databases from this page.

To set up a SQL database link

1. From the Altiris Console, click the Configuration tab.

2. In the left pane, select Configuration > Solutions Settings > Connectors > 
IBM Director > Data Integration.

3. In Select a Configuration, select the IBM Director computer that you want to use 
to set up a link.

The name of the configuration is listed followed by the fields you can enter to 
configure the data integration.

4. Enter the description of the configuration.

5. Enter the IBM Director computer and database information. 

Note
These fields are used for both setting up a database link and importing computer 
resources.

a. In the Server Name field, enter the name of the computer that the IBM 
Director database is on.

b. In the Database Name field, enter the name of the IBM Director database.

c. In the Schema field, enter the IBM Director database schema.

d. In the User field, enter a username for logging onto the IBM Director database 
(example: sa).

e. In the Password field, enter the password for the username.

6. Enter the linked server information. These fields are specific to setting up a linked 
server.

Note
These fields are used only for setting up a database link.

a. In the Product name field when using SQL server, enter SQLServer OLEDB 
Provider.

b. In the Provider name field when using SQL server, enter SQLOLEDB.

c. In the Location field when using SQL server, you can leave it blank.
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d. In the Provider string field when using SQL server, you can leave it blank.

7. Click Apply to establish the database link.

Note

You can test the selected configuration by clicking the Test icon ( ) on the toolbar.

In addition to linking the two databases, you can also import computer resources from 
the IBM Director database to the Notification Database. The computer name and a 
computer identifier are all that get uploaded to the Notification Server. For every 
computer on the IBM Director, a resource is created (if it does not exist) in the 
Notification Database.

To import computer resources to Notification Server

Note
You must create a database link (enter the IBM Director computer, database, and linked 
server information and click Apply) before you can import computer resources.

Option 1: Click the Run the Selected Configuration icon ( ) on the toolbar. This 
creates the database link and imports the computer resources.

Option 2: Select Enable Schedule and select the schedule you want the import to run. 
The import will be run at the scheduled time.

Running a Report on Data from IBM Director
The Connector Pack provides several reports to view your IBM data. After you have 
created a database link or imported computer resources, you can run these reports.

To run a computer hardware inventory report on IBM Director

1. From the Altiris Console, click the Reports tab.

2. In the left pane, select Reports > Connector > IBM Director > Computer 
Hardware Inventory by Model.

3. In the right pane, click Run this report.
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Chapter 4
Using the Connector Pack for IBM Director

This section describes the elements that are added to the Altiris console when this 
Connector Pack gets installed.

Quick Links

! Agent Configuration (page 13)

! Reports (page 14)

Agent Configuration
The Connector Pack Agent integrates IBM Director with the Altiris Infrastructure in two 
ways:

! Event Integration

The event integration between IBM Director and the Altiris Infrastructure is built on 
Connector Solution components. When the Connector Pack creates the installer for 
the Connector Pack Agent, it includes the Altiris MIB and Altiris Custom MIB. When 
the Connector Pack Agent is installed, these MIBs are placed in a folder from which 
they will be imported into IBM Director and used for interpreting received SNMP trap 
events from the Altiris Infrastructure. The task of importing the MIBs into IBM 
Director requires some manual steps.

! UI Integration

The UI integration between IBM Director and the Altiris Infrastructure is built on 
Connector Solution components. When the Connector Pack creates the installer for 
the Connector Pack Agent, it includes files and custom actions required for a 
predefined set of UI integrations. When the Connector Pack Agent is installed, these 
predefined UI integrations are exposed in the IBM Director UI. 

The Connector Pack Agent installer created by the Connector Pack is a standard MSI 
installer. The Connector Pack leverages Altiris Installer Maker to create the installer 
dynamically on demand for manual download from the Altiris console to the IBM Director 
computer, or for automated software delivery from the Altiris Infrastructure to the IBM 
Director computer.

The Agent Configuration page lets you manually or automatically install the Connector 
Pack Agent for IBM Director executable to the IBM Director computer. When you click 
Download the Agent, a File Download window appears. Click Open to download the 
agent to a computer that is accessible by the IBM Director computer. Then, install the 
agent to the IBM Director computer. The agent is installed in the Program 
Files\Altiris\ConnectIBMDirectorAgent folder.

If you want to install the Connector Pack Agent using Software Delivery, click Configure 
Software Delivery to create a software delivery task. Select Enable to enable the 
task, then click Apply to accept the configuration.

If you have Software Delivery Solution installed, you can create a package that deploys 
the Connector Pack Agent for IBM Director to an IBM Director computer (the IBM 
Director computer must already have the Altiris Agent installed before you create the 
Connector Pack for IBM Director Product Guide 13



 

package). Click Configure Software Delivery to create the package. A collection, 
package, and task item is added in the Agent folder for each IBM Director computer for 
which you configure Software Delivery.

Note
Each time Altiris produces a new MIB, you need to download and install the Connector 
Pack Agent to your IBM Director computers.

Reports
The Connector Pack provides several reports that let you view data. 

To run reports

1. From the Altiris Console, click the Reports tab.

2. In the left pane, select Reports > Connector > IBM Director.

3. To run a report, select the report and click Run this report in the right pane.
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