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Chapter 1
Introducing DeskView for Displays

This chapter includes the following topics:

About DeskView for Displays

What’s new in DeskView for Displays

Products installed with DeskView for Displays

How DeskView for Displays works

What you can do with DeskView for Displays

Where to get more information

About DeskView for Displays
DeskView for Displays is a solution developed by Symantec and Fujitsu Technology 
Solutions that lets you inventory and manage Fujitsu Technology Solutions display 
devices remotely from your administrator’s desk. This solution effectively manages 
Fujitsu displays of Premium and Business Line equipped with a VESA-DDC/CI-
compatible interface. DeskView for Displays supports inventory management and 
remote setting of display adjusts.

What’s new in DeskView for Displays
The following new features are introduced in the 10.72 release of DeskView for Displays:

Support of Windows 7

Products installed with DeskView for Displays
The Altiris management products that are installed and used with DeskView for Displays 
are shown in the following table:

How DeskView for Displays works
DeskView for Displays is a software that runs under the Symantec Management Platform 
software. The DeskView Display Agent that you install on the client systems lets you 
discover supported displays manufactured by Fujitsu Technology Solutions. The 
DeskView Display Agent communicates with the Symantec Management Platform and 
lets you perform display management tasks from the Symantec Management Console.

Product Description

Symantec Management Platform The base management platform.
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What you can do with DeskView for Displays

With DeskView you can collect display inventory data and view this inventory in the 
Symantec Management Console. DeskView lets you adjust settings of supported 
displays remotely from the Symantec Management Console.

Where to get more information
Use the following documentation resources to learn and use this product.

Document Description Location

Release Notes Information about new fea-
tures and important issues.

This information is available 
as an article in the Altiris 
Knowledge Base.

http://kb.altiris.com/

You can search for the product name 
under Release Notes.

User’s Guide Information about how to 
use this product, including 
detailed technical informa-
tion and instructions for per-
forming common tasks.

This information is available 
in PDF format.

The Documentation Library, 
which is available in the Syman-
tec Management Console on the 
Help menu.

The Product Support page, 
which is available at the follow-
ing URL: 
http://www.symantec.com/busi-
ness/support/all_products.jsp
When you open your product’s 
support page, look for the Docu-
mentation link on the right side 
of the page.

Help Information about how to 
use this product, including 
detailed technical informa-
tion and instructions for per-
forming common tasks.

Help is available at the solu-
tion level and at the suite 
level.

This information is available 
in HTML help format.

The Documentation Library, which is 
available in the Symantec Manage-
ment Console on the Help menu.
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In addition to the product documentation, you can use the following resources to learn 
about Altiris products.

Resource Description Location

Altiris Knowl-
edgebase

Articles, incidents, and issues 
about Altiris products.

http://kb.altiris.com/

Altiris Juice An online magazine that con-
tains best practices, tips, tricks, 
and articles for users of Altiris 
products.

http://www.altiris.com/
juice/

Online Forums Forums for users of Altiris prod-
ucts.

http://forums.altiris.com/
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Chapter 2
Installing DeskView for Displays

This chapter includes the following topics:

System requirements

Installing the DeskView for Displays product

Uninstalling DeskView for Displays

System requirements
DeskView for Displays has the following system requirements:

DeskView for Displays installation requirements.
See About DeskView for Displays requirements on page 7.

DeskView Display Agent installation requirements.
See About client computer requirements on page 7.

About DeskView for Displays requirements
DeskView for Displays requires the following:

Symantec Management Platform 7.0

For more information on Symantec Management Platform prerequisites and installation 
instructions, see the Symantec Management Platform Help.

See Where to get more information on page 5.

About client computer requirements
The DeskView Display Agent has the following requirements:

Installing the DeskView for Displays product
Use Symantec Installation Manager to install DeskView for Displays.

Requirement Description

Operating system The DeskView Display Agent supports Windows XP 
Professional (32-bit and 64-bit versions) and Windows 7 (all 
versions) operating systems.

Display VESA-DDC/CI-capable display from Fujitsu Technology 
Solutions.

For a detailed list of supported displays and graphic adapters, 
see http://ts.fujitsu.com/solutions/it_infrastructure_solutions/
manageability/index.html.
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For more information on installing products, see the Symantec Management Platform 
Installation Guide.

Uninstalling DeskView for Displays
To uninstall DeskView for Displays perform the following steps:

Uninstalling the DeskView Display Agent from client computers
The DeskView Display Agent - Uninstall policy lets you remove the DeskView Display 
agent from supported client computers. Remove the agent if you do not want to reinstall 
DeskView for Displays later.

The agent’s uninstallation process can take some time to start, depending on the 
intervals set between updates of the Altiris Agent.

See Configuring the Altiris Agent settings for evaluation use on page 11.

We recommend that you do not uninstall the DeskView for Displays software from 
Notification Server until the agent uninstallation task has run on all client computers. 
When DeskView for Displays is uninstalled, there is no automated way to uninstall the 
agent.

To uninstall the DeskView Display Agent

1. In the Symantec Management Console, on the Home menu, click DeskView for 
Displays.

2. In the left pane, click Agents and Plug-ins > DeskView Display Agent - 
Uninstall.

3. Turn on the policy (To turn on the policy, at the upper right of the page, click the 
colored circle, and then click On).

4. Click Save changes.

Uninstalling DeskView for Displays from the Notification Server 
computer

Use Symantec Installation Manager to uninstall DeskView for Displays. 

For more information on uninstalling products, see the Symantec Management Platform 
Installation Guide.

Step Action Description

Step 1 Uninstall the DeskView 
Display Agent from client 
computers.

This step is required if you do not want to 
reinstall DeskView for Displays later.

See Uninstalling the DeskView Display Agent 
from client computers on page 8.

Step 2 Uninstall DeskView for 
Displays from the Notifi-
cation Server computer.

This step removes the product from the Notifi-
cation Server computer.

See Uninstalling DeskView for Displays from 
the Notification Server computer on page 8.
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Chapter 3
Getting started with DeskView for Displays

This chapter includes the following topics:

About the Symantec Management Console

About the DeskView “Home”

About the Symantec Management Console 
You perform all DeskView for Displays configuration and administration tasks in the 
Symantec Management Console.

The Symantec Management Console is the Web-browser-based administration console 
for working with Altiris Notification Server and Altiris solutions, including DeskView for 
Displays. The console lets you perform tasks, schedule events, run reports, perform 
configuration, configure security, and more. You can run the console from the 
Notification Server computer (locally) or from a remote computer with a network 
connection to the Notification Server computer. This means you can perform 
administration tasks from wherever you are.

The console lets you set security specific to each console user. You specify which areas of 
the console a user has access to and the rights a user has to perform specific actions. 
For example, one user can run reports while another user can only view the reports that 
have already been run.

For more information on the console, see the Symantec Management Platform 
documentation, which can be accessed through the console's Help menu.

You can start the console remotely by typing the following URL into Internet Explorer's 
address bar: http://<Notification_Server_name>/altiris/console

About the DeskView “Home”
DeskView for Displays provides a home page that introduces you to DeskView 
components and provides links to common tasks.

To open the DeskView home page, in the Symantec Management Console, on the Home 
menu, click DeskView.



 

Chapter 4
Preparing computers for management

This chapter includes the following topics:

Preparing target systems for management

Discovering computers

Installing the Altiris Agent

Configuring the Altiris Agent settings for evaluation use

Installing the DeskView Display Agent

Viewing DeskView Display Agent installation reports

Preparing target systems for management
The following is the recommended way of preparing target computers for management:

Discovering computers
Discovery lets you find the hostnames of the computers where you can install the Altiris 
Agent. You can discover computers on the network using a domain or a workgroup 
search.

Step Action Description

Step 1 Discover manageable 
computers in your envi-
ronment.

Discovery lets you find computers on which 
you can install the Altiris Agent.

See Discovering computers on page 10.

Step 2 Install the Altiris Agent to 
the client computers.

The Altiris Agent lets Notification Server get 
information from and interact with the client 
computers.

See Installing the Altiris Agent on page 11.

Step 3 (Optional) Configure the 
Altiris Agent settings for 
evaluation use.

For easier configuration and evaluation of 
DeskView for Displays, you can make the Alti-
ris Agent to request configuration from the 
Notification Server more frequently.

See Configuring the Altiris Agent settings for 
evaluation use on page 11.

Step 4 Install the DeskView Dis-
play Agent.

Install the DeskView management software to 
the computers in your environment to dis-
cover and manage supported displays.

See Installing the DeskView Display Agent on 
page 12.
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For more information on resource discovery, see the Symantec Management Platform 
Help.

See Preparing target systems for management on page 10.

To discover computers

1. In the Symantec Management Console, on the Actions menu, click Discover > 
Import Domain Membership/WINS.

2. In the Add Domain box, type the domain name, and then click the Add symbol.

3. Check Domain Membership and click Discover Now.

4. As the discovery process finishes, click View discovery reports.

5. Open a report to view the list of discovered computers.
For example, right-click the Discovered Computers report, and then click Open.

Installing the Altiris Agent
The Altiris Agent is a program that you install on the computers you want to manage, 
allowing the Symantec Management Platform and solutions to get information from and 
interact with your computers. The agent enables computers to receive configuration 
information from and send data to the Notification Server and helps download packages 
as well as tasks and jobs. The agent lets you change settings on the managed computer 
and install and manage various solution-specific plug-ins.

You must install the Altiris Agent on the computers you want to manage with DeskView 
for Displays.

For more information on the Altiris Agent, see the Symantec Management Platform Help.

See Preparing target systems for management on page 10.

To install the Altiris Agent

1. In the Symantec Management Console, on the Actions menu, click Agents/Plug-
ins > Push Altiris Agent.

2. On the Altiris Agent Installation page, install the Altiris Agent to computers in your 
environment.
For more information on how to install the Altiris Agent, see the Symantec 
Management Platform Help (Press F1 or click Help > Context in the Symantec 
Management Console).

Configuring the Altiris Agent settings for evaluation 
use

(Optional)

By default, the Altiris Agent requests new configuration from the Notification Server 
once per hour. This means that it can take up to one hour for a rollout policy (for 
example, the DeskView Discovery Agent - Install policy) to reach the target computer. 

If you are evaluating this solution in a lab environment, you can change the 
configuration request interval to speed up the evaluation process.
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The next time the Altiris Agent downloads configuration information, these settings will 
take effect. If you were using the default agent configuration values before the change, 
updates can take up to one hour before these changes are effective.

See Preparing target systems for management on page 10.

To configure the Altiris Agent for evaluation use

1. In the Symantec Management Console, on the Settings menu, click Agents/Plug-
ins > Targeted Agent Settings.

2. In the left pane, under Policy Name, click the policy that applies to the computers 
that you want to configure. 
For example, click All Desktop computers (excluding 'Package servers').

3. On the General tab, in the Download new configuration every box, change the value 
to 5 minutes.
This forces the agent to check more frequently for changes so you can see the 
results of the changes that you make more quickly.

4. In the Upload basic inventory every box, change the value to 15 minutes.
This forces inventory data to be sent more frequently.

5. Click Save changes.

Installing the DeskView Display Agent
The DeskView Display Agent is a client software package that lets you remotely change 
the display settings on the client computers. 

You can deploy this package remotely on computers with Microsoft Windows XP or later. 
The DeskView Display Agent works only with supported displays from Fujitsu Technology 
Solutions.

See About client computer requirements on page 7.

Installation of the DeskView Display Agent requires the target computers to be 
restarted.

See Preparing target systems for management on page 10.

To install the DeskView Display Agent

1. In the Symantec Management Console, on the Home menu, click DeskView for 
Displays.

2. In the left pane, click Agents and Plug-ins > DeskView Display Agent - Install.

3. Turn on the policy.
To turn on the policy, at the upper right of the page, click the colored circle, and 
then click On.

4. Click Save changes.
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Viewing DeskView Display Agent installation 
reports

DeskView for Displays includes reports that provide information about the status of the 
DeskView Display Agent on your client computer. These reports provide installation and 
execution status of the agents as well as the agents version information.

See Preparing target systems for management on page 10.

To view the DeskView Display Agent installation status reports

1. In the Symantec Management Console, on the Home menu, click DeskView for 
Displays.

2. In the left pane, click Reports > Displays.

3. Click a report.
For example, click the Installation Status DeskView Display Agent report.
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Chapter 5
Using DeskView for Displays

This chapter includes the following topics:

About running tasks and policies

Changing displays settings

Viewing display inventory

About running tasks and policies
You can run DeskView tools using tasks or task-based policies.

If you want a tool to run immediately or on a specific schedule, use tasks to run the tool.

However, the peculiarity of the task is the following: if a client computer happens to be 
offline or turned off at the time the task is scheduled to run, the task will fail to run on 
that computer.

If you want to make sure that, sooner or later, all computers run the tool, use task-
based policies. When turned on, task-based policies are active at all times. When a 
turned-off computer comes back online, it receives and executes the policy.

See Viewing tasks and policies on page 14.

Viewing tasks and policies
You can run DeskView tools using tasks or task-based policies.

See About running tasks and policies on page 14.

To view tasks

1. In the Symantec Management Console, on the Home menu, click DeskView.

2. In the left pane, click Tasks.

To view task-based policies

1. In the Symantec Management Console, on the Home menu, click DeskView.

2. In the left pane, click Policies.

Changing displays settings
The DeskView Display Settings tool lets you perform the following tasks remotely on 
client computers:

Run display auto adjust

Lock/unlock the on-screen display

Set display brightness
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Set color temperature

Reset the display settings to their factory defaults

Before you can use the DeskView Display Settings tool, you must install the DeskView 
Display Agent to client computers.

See Installing the DeskView Display Agent on page 12.

To run a DeskView Display Settings task

1. In the Symantec Management Console, on the Home menu, click DeskView.

2. In the left pane, click Tasks > DeskView Display Settings.

3. Click the task you want to run.

4. In the right pane, configure the task.
For help, in the Symantec Management Console press F1 or click Help > Context

5. Run the task one time or on a schedule. 
For information on running tasks, see the Symantec Management Platform Help.

To run a DeskView Display Settings task-based policy

1. In the Symantec Management Console, on the Home menu, click DeskView.

2. In the left pane, click Policies > DeskView Display Settings.

3. Click the policy you want to run.

4. In the right pane, configure the settings.
For help, in the Symantec Management Console press F1 or click Help > Context

5. Configure the scheduling options.

6. Turn on the policy.
To turn on the policy, at the upper right of the page, click the colored circle, and 
then click On.

7. Click Save changes.

Viewing display inventory
The DeskView Display Agent that is installed on the client computer sends display 
inventory data to Notification Server.

You can view the inventory data of a specific DeskView managed system in the Resource 
Manager.

See Accessing the Resource Manager on page 15.

See Viewing display inventory on page 16.

Accessing the Resource Manager
In the Resource Manager, DeskView for Displays displays information about the display 
that is attached to the client computer.

To open the Resource Manager from computer filters or reports

1. In the Symantec Management Console, on the Home menu, click DeskView.
DeskView for Displays 10.72 15



 

2. Click Filters.

3. Click a filter.
For example, click DeskView managed systems > Professional PCs.

4. In the right pane, double-click the computer for which you want to open the 
Resource Manager. 
The Resource Manager opens in a new window.

To open the Resource Manager directly

1. In the Symantec Management Console, on the Actions menu, click Remote 
Management > Real-Time Management.

2. On the Manage page, enter the host name or the IP of the computer for which you 
want to open the Resource Manager, and then click Connect.

Viewing display inventory
You can view the inventory collected by the DeskView Display Agent in the Resource 
Manager.

To view DeskView inventory

1. Open the Resource Manager window for the computer. 
See Accessing the Resource Manager on page 15.

2. On the View menu, click Inventory.

3. In the tree view pane, expand the DeskView Display Inventory folder.

4. Click the item you want to view.
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Chapter 6
Context-sensitive topics

This chapter includes the following topics:

DeskView Display Settings tool: Auto adjust task

DeskView Display Settings tool: Lock/unlock OSD task

DeskView Display Settings tool: Set brightness task

DeskView Display Settings tool: Set color temperature task

DeskView Display Settings tool: Set factory default preset task

Cleanup Inventory Cache task

DeskView Display Settings tool: Auto adjust task
This task lets you auto-adjust the display settings and geometry.

You must install the DeskView Display Agent before you can run this task.

See Installing the DeskView Display Agent on page 12.

See Changing displays settings on page 14.

DeskView Display Settings tool: Lock/unlock OSD 
task

This task lets you prevent users from changing the display’s settings using the on-screen 
menu.

You must install the DeskView Display Agent before you can run this task.

See Installing the DeskView Display Agent on page 12.

See Changing displays settings on page 14.

The following options are available on this page:

DeskView Display Settings tool: Set brightness task
This task lets you change the brightness of the display.

You must install the DeskView Display Agent before you can run this task.

See Installing the DeskView Display Agent on page 12.

Option Description

Lock/Unlock OSD Click to enable or disable the on-screen display 
on the client computers.
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See Changing displays settings on page 14.

The following options are available on this page:

DeskView Display Settings tool: Set color 
temperature task

This task lets you change the color temperature settings of the display.

You must install the DeskView Display Agent before you can run this task.

See Installing the DeskView Display Agent on page 12.

See Changing displays settings on page 14.

The following options are available on this page:

DeskView Display Settings tool: Set factory default 
preset task

This task lets you reset all display configuration settings to their factory default values.

You must install the DeskView Display Agent before you can run this task.

See Installing the DeskView Display Agent on page 12.

See Changing displays settings on page 14.

Cleanup Inventory Cache task
This task lets you purge the inventory cache, located on the Notification Server 
computer. In case of a default DeskView for Displays installation, the inventory cache is 
located at C:\Program Files\Altiris\DeskView\InventoryCache.

By default, this task is configured to run daily. 

Option Description

Choose brightness Type the brightness value in percent (from 0 to 
100) and click Save changes.

Default: 75

Option Description

Choose color temperature Click the color temperature that you want to set 
on the displays attached to the client computers.
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The following options are available on this page:

Option Description

HDD Free Space Limit Check if you want to purge the cache when the 
free disk space goes below a specific limit.

Type the limit for the minimum amount of free 
space on the hard disk.

Default: 2048 MB

HDD Usage Limit Check if you want to purge the cache when its 
size exceeds a specific limit.

Type the maximum limit for the amount of 
cached data that is saved.

Default: 10 MB
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Appendix A
Glossary

This appendix introduces important terms used in this document.

Altiris Agent

The software that is installed on the computers that you want to manage. It facilitates 
interactions between Notification Server and a managed computer. The agent receives 
requests for information from Notification Server, sends data to Notification Server, and 
downloads files. The Altiris Agent also lets you install and manage solution plug-ins that 
add functionality to the agent.

CMDB (Configuration Management Database)

The central database that stores all information about the Symantec Management 
Platform and its managed computers.

DeskView Display Agent

DeskViewDisplay Agent is a software, installed on the target computers, that provides 
inventory and management of Fujitsu Technology Solutions displays.

discovery

The process of searching for computers or other resources on your network that meet 
specific requirements.

filter

A query that identifies a dynamic group of resources that share common criteria.

job

A group of one or more tasks that are run in a particular sequence. Jobs can include 
conditions that specify when the task runs.

Notification Server

The Symantec Management Platform service that communicates with the Altiris Agent 
and the CMDB to provide management, security, and administrative functionality. It 
processes events, facilitates communications with managed computers, and coordinates 
the work of the other Symantec Management Platform services.

policy

A set of rules that control the execution of automated actions. Policies can be scheduled 
or based on incoming data that triggers an immediate action. Policies determine when 
an action should start and who or what should be notified of the results.

resource

Any item that Notification Server can track or manage, such as a user, site, installed 
application, computer, switch, router, or handheld device.
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Resource Manager

A feature that displays information about a resource, such as its properties and current 
state. It also lets you troubleshoot and perform actions on managed resources.

Symantec Management Console

The Web-based user interface for managing the Symantec Management Platform and 
any other installed solutions.

task

An action that is performed on a computer. Server tasks are run on Notification Server. 
Client tasks are run on managed computers.

VESA-DDC/CI-compatible interface

Display Data Channel/Command Interface defined by Video Electronics Standards 
Association (http://www.vesa.org)
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