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Technical Support
Symantec Technical Support maintains support centers globally. Technical
Support’s primary role is to respond to specific queries about product features
and functionality. The Technical Support group also creates content for our online
Knowledge Base. The Technical Support group works collaboratively with the
other functional areas within Symantec to answer your questions in a timely
fashion. For example, the Technical Support group works with Product Engineering
and Symantec Security Response to provide alerting services and virus definition
updates.

Symantec’s maintenance offerings include the following:

■ A range of support options that give you the flexibility to select the right
amount of service for any size organization

■ Telephone and Web-based support that provides rapid response and
up-to-the-minute information

■ Upgrade assurance that delivers automatic software upgrade protection

■ Global support that is available 24 hours a day, 7 days a week

■ Advanced features, including Account Management Services

For information about Symantec’s Maintenance Programs, you can visit our Web
site at the following URL:

www.symantec.com/techsupp/

Contacting Technical Support
Customers with a current maintenance agreement may access Technical Support
information at the following URL:

www.symantec.com/techsupp/

Before contacting Technical Support, make sure you have satisfied the system
requirements that are listed in your product documentation. Also, you should be
at the computer on which the problem occurred, in case it is necessary to replicate
the problem.

When you contact Technical Support, please have the following information
available:

■ Product release level

■ Hardware information

■ Available memory, disk space, and NIC information

■ Operating system

www.symantec.com/techsupp/
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■ Version and patch level

■ Network topology

■ Router, gateway, and IP address information

■ Problem description:

■ Error messages and log files

■ Troubleshooting that was performed before contacting Symantec

■ Recent software configuration changes and network changes

Licensing and registration
If your Symantec product requires registration or a license key, access our technical
support Web page at the following URL:

www.symantec.com/techsupp/

Customer service
Customer service information is available at the following URL:

www.symantec.com/techsupp/

Customer Service is available to assist with the following types of issues:

■ Questions regarding product licensing or serialization

■ Product registration updates, such as address or name changes

■ General product information (features, language availability, local dealers)

■ Latest information about product updates and upgrades

■ Information about upgrade assurance and maintenance contracts

■ Information about the Symantec Buying Programs

■ Advice about Symantec's technical support options

■ Nontechnical presales questions

■ Issues that are related to CD-ROMs or manuals
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Maintenance agreement resources
If you want to contact Symantec regarding an existing maintenance agreement,
please contact the maintenance agreement administration team for your region
as follows:

contractsadmin@symantec.comAsia-Pacific and Japan

semea@symantec.comEurope, Middle-East, and Africa

supportsolutions@symantec.comNorth America and Latin America

Additional enterprise services
Symantec offers a comprehensive set of services that allow you to maximize your
investment in Symantec products and to develop your knowledge, expertise, and
global insight, which enable you to manage your business risks proactively.

Enterprise services that are available include the following:

These solutions provide early warning of cyber attacks, comprehensive threat
analysis, and countermeasures to prevent attacks before they occur.

Symantec Early Warning Solutions

These services remove the burden of managing and monitoring security devices
and events, ensuring rapid response to real threats.

Managed Security Services

Symantec Consulting Services provide on-site technical expertise from
Symantec and its trusted partners. Symantec Consulting Services offer a variety
of prepackaged and customizable options that include assessment, design,
implementation, monitoring, and management capabilities. Each is focused on
establishing and maintaining the integrity and availability of your IT resources.

Consulting Services

Educational Services provide a full array of technical training, security
education, security certification, and awareness communication programs.

Educational Services

To access more information about Enterprise services, please visit our Web site
at the following URL:

www.symantec.com

Select your country or language from the site index.
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Introducing Real-Time
System Manager

This chapter includes the following topics:

■ About Real-Time System Manager

■ What's new in Real-Time System Manager

■ Products installed with Real-Time System Manager

■ How Real-Time System Manager works

■ What you can do with Real-Time System Manager

■ Where to get more information

About Real-Time System Manager
The Altiris Real-Time System Manager software lets you manage a single computer
from the Symantec Management Console in real time. Real-Time System Manager
can connect to the target computer using the following protocols:

■ Microsoft Windows Management Instrumentation (WMI)

■ Alert Standards Format 2.0 (ASF)

■ Intel® Active Management Technology (Intel® AMT)

■ DASH

With Real-Time System Manager, you can view detailed real-time information
about the managed computer and remotely perform various administrative tasks.
For example, you can restart the computer, reset a password, run a port scan,
terminate a process, and more.

1Chapter



Real-Time System Manager also lets you run some of the management tasks on
a collection of computers, immediately or on a schedule.

What's new in Real-Time System Manager
In the 7.0 release of Real-Time System Manager, the following new features are
introduced:

■ Support for computers with Broadcom DASH technology.

Products installed with Real-Time System Manager
When you install Real-Time System Manager, the following Altiris products are
also installed.

Table 1-1 Products installed with Real-Time System Manager

DescriptionProduct

The base management platform.Symantec Management Platform

Lets you view the SNMP events that the
target computers send to the Notification
Server computer.

Altiris™ Event Console

Provides out-of-band one-to-many
management tasks.

Altiris™ Real-Time Console Infrastructure

Provides the real-time in-band and
out-of-band management infrastructure and
connection profiles to Altiris solutions.

Altiris™ Pluggable Protocols Architecture

Manages connection credentials for different
management technologies that are used in
Pluggable Protocols Architecture.

Altiris™ Credential Manager

How Real-Time System Manager works
When you select a computer you want to manage from the Symantec Management
Console, Real-Time System Manager checks for the remote management
technologies that the target computer supports. The technologies include WMI,
ASF, DASH, and Intel AMT. Then it remotely queries the computer for various
information using these technologies. Real-Time System Manager displays the
actual information that is received from the computer in the Resource Manager's
Real-Time view. From the Real-Time view, you can perform various tasks on the

Introducing Real-Time System Manager
What's new in Real-Time System Manager
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target computer to which Real-Time System Manager is connected and immediately
see the results. With Real-Time System Manager you can manage computers
in-band as well as out-of-band.

See “About the Symantec Management Console” on page 13.

See “About out-of-band management” on page 13.

About the Symantec Management Console
The Symantec Management Console is the Web browser based administration
console for working with Symantec Management Platform and solutions, including
Real-Time System Manager. The console lets you perform tasks, schedule events,
run reports, perform configuration, configure security, and more. You can run
the console from the Notification Server computer (locally) or from a remote
computer with a network connection to the Notification Server. This means you
can perform administration tasks from wherever you are.

The console lets you set security that is specific to each console user. You specify
which areas of the console a user has access to and the rights that a user has to
perform specific actions. For example, one user can run reports while another
user can only view reports that have already been run.

You can start the console remotely by typing the following URL into the Internet
Explorer's address bar: http://<Notification_Server_name>/altiris/console

For more information on the console, see the Symantec Management Platform
Help, which can be accessed through the console's Help menu.

About out-of-band management
Remote management of client computers often requires the managed computer
to be turned on with an operating system running. When a computer is turned
on with a running operating system, the computer is considered in-band.

Out-of-band is when a client computer is in one of the following out-of-band states:

■ The computer is plugged in but is not actively running (off, standby,
hibernating).

■ The operating system is not loaded (software or boot failure).

■ The software-based management agent is not available.

Out-of-band management is the ability to manage computers in these states.
Computers with Intel AMT, ASF, or DASH capabilities can be managed out of
band.

13Introducing Real-Time System Manager
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About one-to-one and one-to-many management
One-to-one management is performed in real time during a live connection between
Real-Time System Manager and the target computer you manage. You can run
management tasks on the target computer and immediately see the results in the
Symantec Management Console, in the Resource Manager's Real-Time view.

See “About the Real-Time view” on page 16.

One-to-many management is when you create a task, assign it to one or more
computers, and configure it to run at a later time.

About Intel AMT
Intel Active Management Technology (Intel AMT) is a part of Intel vPro technology,
which provides the following technology capabilities:

Lets you remotely inventory, diagnose, and repair computers—even
those that are powered off—reducing costly desk-side visits and
increasing user uptime.

Remote manageability

Lets third-party security software identify more threats before
they reach the operating system. You can isolate infected systems
more quickly and update computers regardless of their power
state.

Security

Intel AMT is a solution that is based in hardware and firmware and is connected
to the system's auxiliary power plane. Despite the power state or the operating
system state of the client computer, Intel AMT provides IT administrators with
access to alerts, hardware inventory, power management, circuit breaker, and
agent presence functionality. Intel AMT functionality requires the computer to
be plugged into the power source and connected to the network. Intel AMT
functionality does not require a software agent to be installed on the client
computer.

Altiris Out of Band Management Component, Altiris Real-Time Console
Infrastructure, and Altiris Real-Time System Manager software support Intel
AMT 2.0 and later.

About ASF
ASF (Alert Standard Format) is an industry standards-based technology that lets
IT administrators manage computers regardless of the operating system state.
ASF performs completely out of band and only relies on the operating system to
configure the solution.

Introducing Real-Time System Manager
How Real-Time System Manager works
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ASF provides alerting and power management functionality as long as the
computer is plugged in with Ethernet connection. ASF functionality is
accomplished through hardware on the network card or system board, a software
agent on the client computer, and management software on the server.

Altiris Out of Band Management Component, Altiris Real-Time Console
Infrastructure, and Altiris Real-Time System Manager software support ASF 2.0.

About DASH
DASH (Desktop and Mobile Architecture for System Hardware) is a Web
services-based management technology that enables IT professionals to remotely
manage desktop and mobile computers from anywhere in the world, securely turn
the power on/off, query system inventory, and push firmware updates among
other things, regardless of the state of the remote computer.

Altiris Out of Band Management Component, Altiris Real-Time Console
Infrastructure, and Altiris Real-Time System Manager software support Broadcom
implementation of DASH.

About WMI
Windows Management Instrumentation (WMI) is the Microsoft implementation
of Web-based Enterprise Management (WBEM), which is an industry initiative to
develop a standard technology for accessing management information in an
enterprise environment. WMI uses the Common Information Model (CIM) industry
standard to represent systems, applications, networks, devices, and other managed
components. CIM is developed and maintained by the Distributed Management
Task Force (DMTF).

WMI lets applications obtain management data from remote computers.

About managing target computers without the Altiris Agent installed
To use the full set of features that Altiris solutions offer, we recommend that you
install the Altiris Agent on the computers in your environment. However,
Real-Time System Manager lets you manage computers that do not have the Altiris
Agent installed. If for some reason you choose not to install the Altiris Agent on
the computers, you cannot:

■ Perform one-to-many management tasks on a collection of computers.
Computers without the Altiris Agent installed do not register itself with
Notification Server and are not visible in the computer filters.
See “Running real-time one-to-many tasks” on page 36.

With agentless computers you can:
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■ Manage computers in real time through the Real-Time view.
Agentless computers do not appear in the computer filters—you type the IP
or the hostname of the computer you want to manage into Symantec
Management Console.
See “Running real-time one-to-one tasks” on page 27.

About the Real-Time view
Real-Time System Manager adds its own Real-Time System Manager tree to the
Real-Time view of the Resource Manager. The Resource Manager is a page in the
Symantec Management Console that displays information about an individual
computer.

For more information, see topics about Resource Manager in the Symantec
Management Platform Help.

See “Accessing the Real-Time view” on page 28.

From the Real-Time System Manager tree, you can view live inventory information
about the target computer and perform management tasks in real time.

The Real-Time System Manager tree has various nodes that let you manage the
target computer.

Table 1-2 Real-Time System Manager nodes in the Real-Time view

DescriptionNode

This node is visible only if Real-Time System Manager detects
that the target computer is configured to use Intel AMT.

From this node you can view and change setup and
configuration settings of the target computer's Intel AMT
device.

Configuration

This node lets you view controller and port information.Controllers and Ports

This node lets you view event logs.Event Logs

This node contains input and output device items.Input and Output Devices

From this node, you can turn on, turn off, or restart the
computer, manage printers, users, processes, and services.

Management Operations

This node contains mass storage items.Mass Storage

This node lets you view memory information.Memory

This node contains networking items.Networking
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Table 1-2 Real-Time System Manager nodes in the Real-Time view (continued)

DescriptionNode

This node contains operating system information.Operating System

This node contains firmware and hardware information.Physical System

This page displays the target computer's summary.Summary

Depending on the computer you connect to, you can experience the following
behavior of the Real-Time view:

■ If an item is disabled, then the corresponding WMI class is not supported on
the connected computer.

■ If the WMI class is supported, but there is no instance of it on the computer,
then it is displayed as “No instances found.”

■ If Intel AMT, ASF, or DASH technologies are detected on the target computer,
additional nodes appear in the tree.

The information that is available in the Real-Time System Manager section
includes only a subset of the WMI data. However, you can customize the data that
can be accessed. Contact Symantec Technical Support if you want to create your
own views on the WMI data.

What you can do with Real-Time System Manager
From the Real-Time view, you can perform the following one-to-one tasks:

■ View the target computer's software and hardware information

■ Start and stop processes and services

■ View the printer's configuration and manage printing jobs.

■ Turn off and restart the target computer

■ Turn on the target computer (properly configured out-of-band capable
computer required, use Altiris Out of Band Management Component to
configure computers for out-of-band management)

■ And so on.

See “About the Real-Time view” on page 16.

See “Running real-time one-to-one tasks” on page 27.
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Using Real-Time System Manager with properly configured Intel AMT computers,
you can manage computers that are turned off or have failed to load an operating
system. Intel AMT lets you significantly reduce the number of desk-side visits.

Real-Time System Manager supports the following Intel AMT features:

Lets you change the system boot device to a CD or
to an image that is located on a remote network
drive for system recovery.

See “Booting a computer from another device ”
on page 31.

Remote boot through integrated
device electronics redirection (IDE-R)

Lets you establish a remote console session and
walk the computer through a troubleshooting
session, reinstall the operating system, or change
BIOS settings.

See “Starting a remote control session ” on page 30.

Remote console redirection through
Serial-over-LAN (SOL)

Lets you block all inbound and outbound network
traffic from infected computers and prevent
threats from spreading.

See “Filtering network traffic ” on page 32.

Hardware filtering of network traffic
(Circuit Breaker) using Intel vPro
System Defense technology

Real-Time System Manager also lets you perform some of the tasks on a collection
of computers. You can run the tasks immediately or on a schedule.

See “Running real-time one-to-many tasks” on page 36.

The following one-to-many tasks are available:

Lets you boot a group of computers from either a PXE,
a floppy/HDD/CD device, or an image that is located on
a hard drive.

See “Booting multiple computers from another device ”
on page 37.

Boot redirection task (Intel AMT,
ASF, DASH)

Lets you block network traffic to and from the client
computers' operating system.

See “Filtering network traffic on multiple computers ”
on page 38.

Network filtering task (Intel
AMT)

Lets you reset a password for a local user account
remotely on a group of computers.

See “Resetting a local user password on multiple
computers” on page 39.

Password management task
(WMI)

Introducing Real-Time System Manager
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Lets you start or stop a process remotely on a group of
computers.

See “Running or stopping a process on multiple
computers” on page 39.

Process management task (WMI)

Lets you control a service remotely on a group of
computers in the following ways:

■ Start

■ Stop

■ Restart

■ Change start mode to Automatic, Manual, or Disabled.

See “Running or stopping a service on multiple
computers” on page 40.

Service management task (WMI)

Where to get more information
Use the following documentation resources to learn and use this product.

Table 1-3 Documentation resources

LocationDescriptionDocument

http://kb.altiris.com/

You can search for the product name under
Release Notes.

Information about new features and
important issues.

This information is available as an article in
the Altiris Knowledge Base.

Release Notes

■ The Documentation Library, which is
available in the Symantec Management
Console on the Help menu.

■ The Product Support page, which is
available at the following URL:

http://www.symantec.com/business
/support/all_products.jsp

When you open your product’s support
page, look for the Documentation link on
the right side of the page.

Information about how to use this product,
including detailed technical information and
instructions for performing common tasks.

This information is available in PDF format.

User’s Guide
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Table 1-3 Documentation resources (continued)

LocationDescriptionDocument

The Documentation Library, which is
available in the Symantec Management
Console on the Help menu.

Context-sensitive help is available for most
screens in the Symantec Management
Console.

You can open context-sensitive help in the
following ways:

■ The F1 key

■ The Context command, which is available
in the Symantec Management Console
on the Help menu.

Information about how to use this product,
including detailed technical information and
instructions for performing common tasks.

Help is available at the solution level and at
the suite level.

This information is available in HTML help
format.

Help

In addition to the product documentation, you can use the following resources to
learn about Altiris products.

Table 1-4 Altiris information resources

LocationDescriptionResource

http://kb.altiris.com/Articles, incidents, and issues about Altiris
products.

Altiris Knowledge Base

http://www.altiris.com/juiceAn online magazine that contains best
practices, tips, tricks, and articles for
users of Altiris products.

Altiris Juice

http://forums.altiris.com/Forums for users of Altiris products.Online forums
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Installing Real-Time System
Manager

This chapter includes the following topics:

■ System requirements

■ Installing the Real-Time System Manager product

■ Uninstalling Real-Time System Manager

System requirements
Real-Time System Manager has the following requirements:

■ Real-Time System Manager installation requirements
See “About Real-Time System Manager installation requirements” on page 21.

■ Client computer software requirements
See “About client computer software requirements” on page 21.

■ Client computer hardware requirements
See “About client computer hardware requirements” on page 22.

About Real-Time System Manager installation requirements
Real-Time System Manager requires Symantec Management Platform 7.0.

For more information on the Symantec Management Platform prerequisites and
installation instructions, see the Symantec Management Platform Help.

About client computer software requirements
The computers you want to manage must meet specific software requirements.
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Table 2-1 Client computer software requirements

RequirementsOperating system

A firewall is configured to accept WMI
incoming connections.

See “Configuring the firewall to allow WMI
connection” on page 55.

Microsoft Windows 2000 Professional SP4
or later

About client computer hardware requirements
If you want to use the out-of-band functionality of Real-Time System Manager,
the managed computers must support any combination of the following
out-of-band management technologies.

Table 2-2 Client computer hardware requirements

DescriptionTechnology

Computers with Intel AMT have an Intel
vPro or Centrino Pro label on them.

Intel AMT 2.0, 2.1, 2.5, 2.6, 3.0, 4.0, or 5.0

The Broadcom and Intel implementations of
ASF are supported.

Broadcom ASF 2.0 or Intel ASF 2.0

Only the Broadcom implementation of DASH
is currently supported.

Broadcom DASH

Installing the Real-Time System Manager product
Use Symantec Installation Manager to install Real-Time System Manager.

For more information on installing products, see the Symantec Management
Platform Installation Guide.

Uninstalling Real-Time System Manager
Use Symantec Installation Manager to uninstall Real-Time System Manager.

For more information on uninstalling products, see the Symantec Management
Platform Installation Guide.

Installing Real-Time System Manager
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Preparing target computers
for management

This chapter includes the following topics:

■ Preparing target computers for management

Preparing target computers for management
Before you can use Real-Time System Manager, you must prepare the computers
that you want to manage.

Table 3-1 Process for preparing target computers for management

DescriptionActionStep

Discovery helps you find the hostnames
of the computers on which you can
install the Altiris Agent.

See “Discovering computers”
on page 24.

Discover manageable computers
in your environment.

Step 1
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Table 3-1 Process for preparing target computers for management (continued)

DescriptionActionStep

The Altiris Agent lets Notification
Server get information from and
interact with the client computers.

See “Installing the Altiris Agent”
on page 25.

For one-to-one management, the Altiris
Agent is optional. The Altiris Agent is
required if you want to run
one-to-many management tasks.

See “About one-to-one and one-to-many
management” on page 14.

See “About managing target computers
without the Altiris Agent installed”
on page 15.

Install the Altiris Agent to target
computers.

Step 2

A firewall can prevent Real-Time
System Manager from connecting to
the target computer through the WMI
interface.

See “Configuring the firewall to allow
WMI connection” on page 55.

Configure a firewall on the target
computers.

Step 3

If you have computers with Intel AMT,
ASF, or DASH capabilities in your
environment, configure them for
out-of-band management. This lets you
take the full advantage of Real-Time
System Manager.

See “About out-of-band management”
on page 13.

See “Configuring out-of-band capable
computers” on page 25.

Configure out-of-band capable
computers for out-of-band
management.

Step 4

Discovering computers
Discovery lets you find the hostnames of the computers where you can install the
Altiris Agent. You can discover computers on the network using a domain or a
workgroup search.

Preparing target computers for management
Preparing target computers for management
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For more information on resource discovery, see the Symantec Management
Platform Help.

To discover computers

1 In the Symantec Management Console, on the Actions menu, click Discover
> Import Domain Membership/WINS.

2 In the Add Domain box, type the domain name, and then click the Add symbol.

3 Check Domain Membership, and then click Discover Now.

4 As the discovery process finishes, click View discovery reports to view the
list of discovered computers.

Installing the Altiris Agent
The Altiris Agent is a program that you install on the computers that you want
to manage. The Altiris Agent lets the Symantec Management Platform and
solutions get information from and interact with your computers. The agent
enables computers to receive configuration information from and send data to
the Notification Server, and it helps download packages as well as tasks and jobs.
The agent lets you change settings on the managed computer and install and
manage various solution-specific plug-ins.

You must install the Altiris Agent on the computers that you want to manage with
Real-Time System Manager.

For more information on the Altiris Agent, see theSymantecManagementPlatform
Help.

To install the Altiris Agent

1 In the Symantec Management Console, on the Actions menu, click
Agents/Plug-ins > Push Altiris Agent.

2 On the Altiris Agent Installation page, install the Altiris Agent to computers
in your environment.

For more information on how to install the Altiris Agent, see the Symantec
ManagementPlatformHelp (Press F1 or click Help>Context in the Symantec
Management Console).

Configuring out-of-band capable computers
You must properly configure out-of-band capable computers to connect to those
computers using the out-of-band management technologies.
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To configure computers for out-of-band management

◆ Install and use the Altiris Out of Band Management Component software.

For more information, see the Out of BandManagement Component
Implementation Guide.

Preparing target computers for management
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Using Real-Time System
Manager

This chapter includes the following topics:

■ Running real-time one-to-one tasks

■ Running real-time one-to-many tasks

Running real-time one-to-one tasks
One-to-one computer management is performed from the Resource Manager's
Real-Time view, in the Real-Time System Manager section.

See “About the Real-Time view” on page 16.

See “Accessing the Real-Time view” on page 28.

For example, you can run the following real-time one-to-one tasks:

■ Remotely turn on, turn off, or restart the target computer.
See “Turning off, turning on, or restarting a computer” on page 29.

■ Start a remote control session (SOL) on a computer with Intel AMT to change
BIOS settings.
See “Starting a remote control session ” on page 30.

■ Boot an Intel AMT, ASF, or DASH computer from another device to diagnose
and fix the operating system problems.
See “Booting a computer from another device ” on page 31.

■ Isolate an infected Intel AMT computer from the network.
See “Filtering network traffic ” on page 32.

■ Configure computer health monitoring.
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See “Configuring alerts ” on page 33.

■ Configure the Intel AMT device settings.
See “Configuring the Intel AMT device settings ” on page 35.

■ View the Intel AMT log that is stored in the NVRAM of the target computer.
See “Viewing an Intel AMT log ” on page 36.

Accessing the Real-Time view
The Real-Time view is located in the Resource Manager.

You can open the Resource Manager in the following ways:

■ From a computer filter or a report
Use this method for managed computers that are registered with Notification
Server.
See “To open the Real-Time view from computer filters or reports” on page 28.

■ From the Real-Time System Manager resolution tools
Use this method for unmanaged computers that do not have the Altiris Agent
installed.
See “To open the Real-Time view from the Real-Time System Manager
resolution tools” on page 29.

To open the Real-Time view from computer filters or reports

1 In the Symantec Management Console, select the computer that you want to
manage from the list of discovered resources, any computer filter, or a report.

For example, you can do one of the following:

■ In the Symantec Management Console, on the Manage menu, click Filters.
In the left pane, click Computer Filters > All Computers. In the right
pane, click the computer that you want to manage.

■ Discover computers and click View discovery reports to view the list of
discovered computers. In the report, click the computer that you want to
manage.
See “Discovering computers” on page 24.

2 Right-click the selected computer and click Resource Manager.

3 In the Resource Manager, on the View menu, click Real-Time.

4 In the tree view pane, click Real-Time Consoles.

See “About the Real-Time Consoles page” on page 29.

Using Real-Time System Manager
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To open the Real-Time view from the Real-Time System Manager resolution tools

1 In the Symantec Management Console, on the Actions menu, click Remote
Management > Real-Time Management.

2 On the Manage page, type the host name or the IP of the computer you want
to connect to, and then click Connect.

3 In the Resource Manager, on the View menu, click Real-Time.

4 In the tree view pane, click Real-Time Consoles.

See “About the Real-Time Consoles page” on page 29.

About the Real-Time Consoles page
The Real-Time Consoles page is the first page in the Resource Manager's Real-Time
view tree. It displays the connection information for the computer, the list of
protocols that the target computer supports (WMI, ASF, DASH, Intel AMT), and
if the target computer accepts the connection credentials that you configured.

If credentials are displayed as invalid, verify that your connection profile is
configured to use the correct credentials.

Under Supported protocols, you can select a connection profile to use when
connecting to the target computer.

You can use Credential Manager to add or modify credentials. Then you can use
Connection Profiles to create or modify a connection profile for a specific
technology.

For more information, see the Symantec Management Platform Help.

Turning off, turning on, or restarting a computer

Note: The availability of power commands depends on the current power state
and the technologies (WMI, ASF, Intel AMT, DASH) that are available on the target
computer. For example, WMI power management is limited to reboot and power
off and can be performed on a computer with a running operating system. This
is because WMI is an in-band functionality.

For computers with Intel Active Management Technology (Intel AMT), you can
configure the Redirection options before restarting or turning on the computer.

See “Starting a remote control session ” on page 30.

See “Booting a computer from another device ” on page 31.
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Warning:Before restarting the target computer, make sure that Redirection status
displays no active SOL or IDE-R sessions or you will cause the sessions to terminate.

To perform a power management action

1 Open the Real-Time view for the computer you want to manage.

See “Accessing the Real-Time view” on page 28.

2 Click Real-Time System Manager > Management Operations > Manage
Power State and Redirection.

3 Under Remote power management, select a power action.

4 If you want to perform a graceful restart or shutdown through the WMI,
check Graceful power action.

If the WMI operation fails, the hard shutdown of the target computer is
performed out of band using ASF, DASH, or Intel AMT. The hard shutdown
is possible if any of these technologies are supported and properly configured
on the target computer.

5 Click Run task now.

Starting a remote control session
(Intel AMT only)

The Intel AMT feature Serial-over-LAN (SOL) lets you access the computer's BIOS
remotely using the remote terminal window and change settings.

To use the SOL and IDE-R capabilities of the Intel AMT client computers that are
configured in Secure Mode, their Fully Qualified Domain Name (FQDN) must be
resolved correctly on the Notification Server computer. Also, you must configure
the Protocol Manager to use the right certificates for authentication.

For more information, see theOutofBandManagementComponent Implementation
Guide.

If the SOL session cannot start, make sure the Intel AMT device is configured to
allow this functionality.

See “Configuring the Intel AMT device settings ” on page 35.

To start a SOL session

1 Open the Real-Time view for the computer you want to manage.

See “Accessing the Real-Time view” on page 28.

2 Click Real-Time System Manager > Management Operations > Manage
Power State and Redirection.
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3 Under Redirection options, check Displaytaskprogressandremotelycontrol
computer to create a new SOL session after you turn on the target computer.

Note that, if the session is closed from the client side (for example, the
computer is restarted locally), the Remote Control Terminal is not closed
automatically. In this case, you must close the terminal window manually.

Warning: If there is already an active SOL session, it will be terminated when
the task runs.

4 If you want to change the BIOS settings remotely during the SOL session,
check Enter BIOS on startup.

Note that, when you exit the client computer's BIOS, the client computer
stops sending the information to the terminal. However, the Remote Control
Terminal windows is not closed automatically. In this case, you must close
the terminal window manually.

5 Turn on or restart the computer.

See “Turning off, turning on, or restarting a computer” on page 29.

To view the details of an active SOL session

1 On the Manage Power State and Redirection page, click Details to open the
Redirection Details dialog box.

2 (Optional) To disconnect a SOL session, click Stop remote control.

3 Click Close.

Booting a computer from another device
(Intel AMT, ASF, DASH)

The Intel AMT, ASF, and DASH technologies let you boot the target computer
from a remote disk drive or image. This feature lets you diagnose and fix the
operating system problems.

To use the SOL and IDE-R capabilities of the Intel AMT client computers that are
configured in Secure Mode, their Fully Qualified Domain Name (FQDN) must be
resolved correctly on the Notification Server computer. Also, you must configure
the Protocol Manager to use the right certificates for authentication.

For more information, see theOutofBandManagementComponent Implementation
Guide.

If the IDE-R session cannot start, make sure the Intel AMT device is configured
to allow this functionality.
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See “Configuring the Intel AMT device settings ” on page 35.

You can also run this task on multiple computers, immediately or on a schedule.

See “Booting multiple computers from another device ” on page 37.

To start an IDE-R session

1 Open the Real-Time view for the computer you want to manage.

See “Accessing the Real-Time view” on page 28.

2 Click Real-Time System Manager > Management Operations > Manage
Power State and Redirection.

3 Check Perform boot from.

Warning: If there is already an active IDE-R session, it will be terminated when
the task runs.

4 Select the device to boot from.

5 To start the computer from an image, click Browse to navigate to a network
share where the image is located.

Warning: Do not use an image file placed on a CD or a DVD-ROM to start the
computer. Use only images that are stored on local or network hard disk
drives.

6 Turn on or restart the computer.

See “Turning off, turning on, or restarting a computer” on page 29.

To view details of active IDE-R session

1 On the Manage Power State and Redirection page, click Details to open the
Redirection Details dialog box.

2 (Optional) To disconnect a boot device, click Stop redirection.

3 Click Close.

Filtering network traffic
(Intel AMT only)

The network filtering (Circuit Breaker) functionality on Intel AMT lets you block
network traffic from and to the target computer's operating system. For example,
you can use this feature to isolate an infected computer from the network.

Using Real-Time System Manager
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Note:Network filtering works only if both client operating system and Intel AMT
network settings are configured to use Dynamic Host Configuration Protocol
(DHCP).

Some ports stay open when network filtering is active.

See “About network filtering ports and settings” on page 63.

You can also run this task on multiple computers, immediately or on a schedule.

See “Filtering network traffic on multiple computers ” on page 38.

To block all incoming and outgoing traffic from the target computer's operating
system

1 Open the Real-Time view for the computer you want to manage.

See “Accessing the Real-Time view” on page 28.

2 Click Real-Time System Manager > Networking > Intel AMT Network
Filtering.

3 Click Filter network traffic other than to and from the Notification Server.

4 If you want to prevent the target computer from sending malicious packets,
check Enable anti-spoofing filter.

This forces the identity verification of outgoing network traffic and drops
packets if the computer is suspected of originating malicious attacks that are
known as IP spoofing.

5 Click Save changes.

To protect the target computer from network flooding

1 Open the Real-Time view for the computer you want to manage.

See “Accessing the Real-Time view” on page 28.

2 Click Real-Time System Manager > Networking > Intel AMT Network
Filtering.

3 Click Limit the number of PING packets to and type the number of packets
per second allowed to pass through the Intel vPro network filter.

Default: 10 packets per second.

4 Click Save changes.

Configuring alerts
(Intel AMT, ASF, DASH)
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You can specify the custom destination for SNMP alerts (PETs). For a computer
with Intel AMT or DASH, you can specify which alerts to log and send.

You cannot directly disable ASF alerts using Real-Time System Manager, but you
can modify the SNMP server and SNMP community settings appropriately
specifying a non-existent destination for ASF alerts. For example, you can type
0.0.0.0. If the destination does not respond to ping, ASF alerts are disabled.

To change the PETs destination

1 Open the Real-Time view for the computer you want to manage.

See “Accessing the Real-Time view” on page 28.

2 Click Real-Time System Manager > Management Operations > Manage
Alerts.

3 Under Subscription settings, type the SNMP server’s IP.

This value is applied to computers with Intel AMT and ASF.

By default, the task is configured with the Notification Server computer’s IP.
In this case, the Altiris™ Event Console software, which is installed on the
Notification Server computer, accepts and displays the SNMP events that are
sent by the client computers.

4 Type the SNMP community string.

Example: public

5 Type the destination URI for DASH alerts. By default, the value is set to the
Notification Server's Web service event listener, which is part of the Protocol
Manager: http://<Notification Server IP>/Altiris/WSEL/wsel.aspx

6 Select a DASH alerts delivery mode. The options are as follows:

DASH client computer does not verify if the alert was
accepted by the event listener.

Push

DASH client computer verifies if the alert was accepted by
the event listener. If the event listener does not reply, the
client computer can unsubscribe this particular event filter
(vendor dependent).

Push with acknowledge

7 Click Save changes.
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To subscribe to alerts (Intel AMT and DASH only)

1 Open the Real-Time view for the computer you want to manage.

See “Accessing the Real-Time view” on page 28.

2 Click Real-Time System Manager > Management Operations > Manage
Alerts.

3 Under Select and configure event filters, configure the alerts.

The options are as follows:

Adds a new alert subscription.Add

Removes the alert from the client computer's memory and reclaim
space.

Remove

Activates the alert. When the alert triggers, a message is sent to the
destination address that you configured under Subscription settings.

Subscribe

Deactivates the alert, but does not remove it from the memory.Unsubscribe

4 (Intel AMT only) If you want to remove all previous alert subscriptions from
the client computer and reclaim space before applying new subscriptions,
check Remove 3rd party filters and alert subscriptions.

5 Click Save Changes.

Configuring the Intel AMT device settings
(Intel AMT only)

You can enable or disable starting SOL and IDE-R sessions and change Intel AMT
power-saving settings.

To allow SOL and IDE-R sessions

1 Open the Real-Time view for the computer you want to manage.

See “Accessing the Real-Time view” on page 28.

2 Click Real-Time System Manager > Configuration > Intel AMT Settings.

3 To allow the target computer starting a SOL session, check Task progress
window and remote control.

4 To allow the target computer starting an IDE-R session, check Redirect to
optical/floppy drive or image on a server.

5 Click Save Changes.
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To change the Intel AMT power-saving settings

1 Open the Real-Time view for the computer you want to manage.

See “Accessing the Real-Time view” on page 28.

2 Click Real-Time System Manager > Configuration > Intel AMT Settings.

3 To allow the Intel AMT device to enter sleep state, check UseManageability
Engine's power saving mode after and type the timeout value.

Example: 5 minutes.

4 Click Save Changes.

See “Starting a remote control session ” on page 30.

See “Booting a computer from another device ” on page 31.

Viewing an Intel AMT log
(Intel AMT only)

You can view Intel AMT events stored in the target Intel AMT computer's NVRAM.

To view the Intel AMT log

1 Open the Real-Time view for the computer you want to manage.

See “Accessing the Real-Time view” on page 28.

2 Click Real-Time System Manager > Event Logs > Intel AMT Event Log.

Running real-time one-to-many tasks
When you manage a computer from the Real-Time view, you can configure just
one computer at a time. This is considered a one-to-one management. If you want
to perform the same task on many computers, you can use one-to-many tasks.

Real-Time System Manager installation integrates one-to-many tasks into the
Task Server infrastructure, under Manage > System Jobs and Tasks > Real-Time
System Manager.

For more information on Task Server, see the Symantec Management Platform
Help.

You can run the following real-time one-to-many tasks:

■ Boot redirection task (Intel AMT, ASF, DASH)
See “Booting multiple computers from another device ” on page 37.

■ Network filtering task (Intel AMT)
See “Filtering network traffic on multiple computers ” on page 38.
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■ Password management task (WMI)
See “Resetting a local user password on multiple computers” on page 39.

■ Process management task (WMI)
See “Running or stopping a process on multiple computers” on page 39.

■ Service management task (WMI)
See “Running or stopping a service on multiple computers” on page 40.

Booting multiple computers from another device
(Intel AMT, ASF, DASH)

You can boot the computers with ASF, DASH, or Intel AMT from a remote disk
drive or image.

You can also perform this task on a single computer in real time.

See “Booting a computer from another device ” on page 31.

To start the computers from a remote location

1 In the Symantec Management Console, on the Manage menu, click Jobs and
Tasks.

2 In the left pane, click System Jobs and Tasks > Real-Time System Manager.

3 Click Boot Redirection.

4 In the right pane, select a device to boot from.

5 To start the computer from an image, click Browse to navigate to a network
share where the image is located.

Warning: Do not use an image file placed on a CD or a DVD-ROM to start the
computer. Use only images stored on local or network hard disk drives.

6 Click Save changes.

7 Run the task one time or on a schedule.

For information on how to run tasks, see the SymantecManagementPlatform
Help.

Warning: If there is already an active IDE-R session, it will be terminated when
the task runs.
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Filtering network traffic on multiple computers
(Intel AMT only)

The network filtering (Circuit Breaker) functionality on Intel AMT lets you block
network traffic from and to the target computer's operating system. For example,
you can use this feature to isolate an infected computer from the network.

Note:Network Filtering works only if both client operating system and Intel AMT
network settings are configured to use Dynamic Host Configuration Protocol
(DHCP).

Some ports stay open when network filtering is active. You can customize the
ports to keep open.

See “About network filtering ports and settings” on page 63.

You can also perform this task on a single computer in real time.

See “Filtering network traffic ” on page 32.

To apply the network filtering settings

1 In the Symantec Management Console, on the Manage menu, click Jobs and
Tasks.

2 In the left pane, click System Jobs and Tasks > Real-Time System Manager.

3 Click Network Filtering.

4 If you want to block network traffic to and from the operating system, do the
following steps:

■ Click Filter network traffic other than to and from the Notification
Server.

■ Choose if you want to use the solution default filtering settings or browse
for a custom .xml file.
See “Network Filters page” on page 51.

■ If you want to prevent the target computer from sending malicious packets,
check Enable anti-spoofing filter to force the identity verification of
outgoing network traffic and drop packets if the computer is suspected
of originating malicious attacks, known as IP spoofing.

5 If you want to protect the target computer from network flooding, click Limit
the number of PING packets to and type the number of packets per second
allowed to pass through the Intel vPro network filter.

Default: 10 packets per second.
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6 If you want to disable network filtering, click Allow all network traffic.

7 Click Save changes.

8 Run the task one time or on a schedule.

For information on how to run tasks, see the SymantecManagementPlatform
Help.

Resetting a local user password on multiple computers
You can reset the password for a local user on the target computers.

You can also perform this task on a single computer in real time.

See “Running real-time one-to-one tasks” on page 27.

To reset a password

1 In the Symantec Management Console, on the Manage menu, click Jobs and
Tasks.

2 In the left pane, click System Jobs and Tasks > Real-Time System Manager.

3 Click Password Management.

4 Type the user name to reset the password for in the following format:
COMPUTER\User or DOMAIN\User

5 Type and confirm a new password.

6 Type the name and password of an administrative user with permissions to
manage the specified user account.

7 Click Save changes.

8 Run the task one time or on a schedule.

For information on how to run tasks, see the SymantecManagementPlatform
Help.

Running or stopping a process on multiple computers
You can run or end a process on the target computers.

You can also perform this task on a single computer in real time.

See “Running real-time one-to-one tasks” on page 27.

To run or end a process

1 In the Symantec Management Console, on the Manage menu, click Jobs and
Tasks.

2 In the left pane, click System Jobs and Tasks > Real-Time System Manager.
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3 Click Password Management.

4 Type the name of the process to run or end.

Example: AeXNSAgent.exe

You can also type a full UNC path (Example: \\server\share\AeXNSAgent.exe)
as long as you have the authentication infrastructure to support that. This
means that either you have no authentication (null session shares) or you
have Kerberos with the intermediate computer trusted for delegation, and
delegatable credentials for the user.

5 Select an action.

6 Click Save changes.

7 Run the task one time or on a schedule.

For information on how to run tasks, see the SymantecManagementPlatform
Help.

Running or stopping a service on multiple computers
You can start, stop, restart a service on the target computers and change the
startup mode of a service.

You can also perform this task on a single computer in real time.

See “Running real-time one-to-one tasks” on page 27.

To manage a service

1 In the Symantec Management Console, on the Manage menu, click Jobs and
Tasks.

2 In the left pane, click System Jobs and Tasks > Real-Time System Manager.

3 Click Service Management.

4 Type the name of the service to manage.

Example: cisvc

5 Select an action.

6 Click Save changes.

7 Run the task one time or on a schedule.

For information on how to run tasks, see the SymantecManagementPlatform
Help.
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Context-sensitive topics

This chapter includes the following topics:

■ Configuration node: Intel AMT Configuration mode page (Intel AMT only)

■ Configuration node: Intel AMT Settings page (Intel AMT only)

■ Configuration node: Intel Remote Access Policy page (Intel AMT 4.0 and later
only)

■ Controllers and Ports node

■ Event Logs node

■ Input and Output Devices node

■ Management Operations node: Manage Alerts page

■ Management Operations node: Manage Local Users and Groups page

■ Management Operations node: Manage Power State and Redirection page

■ Management Operations node: Manage Printers page

■ Management Operations node: Manage Processes page

■ Management Operations node: Manage Services page

■ Mass Storage node

■ Memory node

■ Networking node

■ Operating System node

■ Physical System node

■ Summary page
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■ Network Filters page

Configuration node: Intel AMT Configuration mode
page (Intel AMT only)

This page is available only if Real-Time System Manager detects that the target
computer is configured to use Intel AMT.

The page lets you unconfigure the Intel AMT device on the client computer.

Table 5-1 Options on the Configuration node: Intel AMT Configuration mode
page

DescriptionOption

Removes all Intel AMT settings except for administrative user
credentials and PID-PPS pairs. After partial unconfiguration is
complete, the Intel AMT client computer starts sending
configuration requests to the setup and configuration server.
Until the computer is configured by the setup and configuration
server, it is not available for management through the Intel AMT
interface.

For more information on the Intel AMT initialization, setup, and
configuration, see the Out of BandManagement Component
Implementation Guide.

Unconfiguration
method: Partial

Removes all settings from the Intel AMT device. You have to
initialize, setup, and configure the device again. If you choose
Full unconfiguration, you can also select a Small Business or
Enterprise configuration model to set after unconfiguration is
complete.

For details on Intel AMT initialization, setup, and configuration,
see the Out of BandManagement Component Implementation
Guide.

Unconfiguration
method: Full

Configuration node: Intel AMT Settings page (Intel
AMT only)

See “Configuring the Intel AMT device settings ” on page 35.
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Configuration node: Intel Remote Access Policy page
(Intel AMT 4.0 and later only)

This page is available only if Real-Time System Manager detects that the target
computer is configured to use Intel AMT.

This page lets you view the Client Initiated Remote Access policies which the
client computer is configured to use. If there is an active session, this page lets
you close the session.

For more information on configuring Remote Access Policies, see theOut of Band
Management Component Implementation Guide.

Table 5-2 Options on the Configuration node: Intel Remote Access Policy

DescriptionOption

This option is enabled when there is an active Remote Access session on
the target computer.

This option ends the session.

Close session

Controllers and Ports node
This node lets you view controller and port information.

Table 5-3 Pages under the Controllers and Ports node

DescriptionPage

Displays IDE controller information.IDE Controller

Displays parallel port information.Parallel Port

Displays SCSI controller information.SCSI Controller

Displays serial port information.Serial Port

Displays USB controller information.USB Controller

Displays USB hub information.USB Hub

Event Logs node
This node lets you view event logs.
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Table 5-4 Pages under the Event Logs node

DescriptionPage

Displays the application event log.Application Log

Displays the security event log.Security Log

Displays the system event log.System Log

The following log is only available for computers with Intel AMT:

Table 5-5 Intel AMT pages under the Event Logs node

DescriptionPage

Displays the Intel AMT event log stored in the NVRAM on the
managed computer.

Intel AMT Event Log

The following logs are only available for Active Directory controllers:

Table 5-6 Active Directory controller pages under the Event Logs node

DescriptionPage

Displays the directory service log.Directory Service

Displays Domain Name Server (DNS) log.DNS Server

Displays the file replication service event log.File Replication Service

Input and Output Devices node
This node contains input and output devices items.

Table 5-7 Pages under the Input and Output Devices node

DescriptionPage

Displays keyboard information.Keyboard

Displays modem information.Modem

Displays monitor information.Monitor

Displays pointing device information.Pointing Device

Displays local printer information.Printer
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Table 5-7 Pages under the Input and Output Devices node (continued)

DescriptionPage

Displays video adapter information.Video Adapter

Management Operations node: Manage Alerts page
See “Configuring alerts ” on page 33.

Management Operations node: Manage Local Users
and Groups page

This page lets you view local users, groups and their details on the target computer.

Table 5-8 Options on the Management Operations node: Manage Local Users
and Groups page

DescriptionOption

Lets you rename the selected user or group.Rename

Lets you view properties of the selected user or group.Properties

Lets you reset the password for the selected user.

To reset a local user password on multiple computers, immediately or
on a schedule, use the Password Management task.

See “Resetting a local user password on multiple computers” on page 39.

Reset Password

Management Operations node: Manage Power State
and Redirection page

See “Turning off, turning on, or restarting a computer” on page 29.

See “Starting a remote control session ” on page 30.

See “Booting a computer from another device ” on page 31.

ManagementOperations node:ManagePrinters page
This page lets you manage printers and print jobs on the target computer.
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Table 5-9 Options on the Management Operations node: Manage Printers
page

DescriptionOption

Uninstalls selected printers from the target computer.Remove

Cancels all print jobs.Cancel all jobs

Pauses all print jobs.Pause all jobs

Resumes all print jobsResume all jobs

Sends a test page to the selected printer.Print test page

Management Operations node: Manage Processes
page

This page lets you run or stop a process on the target computer.

To run or terminate a process on multiple computers, immediately or on a schedule,
use the Process Management task.

See “Running or stopping a process on multiple computers” on page 39.

Table 5-10 Options on the Management Operations node: Manage Processes
page

DescriptionOption

Lets you run a process. In the Run Application dialog box, type the name of
the application you want to run on the target computer. Click OK.

Note: Due to WMI security restrictions, the program you run using this task
will run in another session on most operating systems. Users cannot see this
application running unless they look it up in the Windows Task Manager.

Run

Lets you terminate the process that you selected.Terminate

ManagementOperations node:ManageServices page
This page lets you run or stop a service on the target computer.

To run, stop, or configure a service on multiple computers, immediately or on a
schedule, use the Service Management task.

See “Running or stopping a service on multiple computers” on page 40.
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Table 5-11 Options on the Management Operations node: Manage Services
page

DescriptionOption

Starts the selected service.Start

Stops the selected service.Stop

Restarts the selected service.Restart

Pauses the selected service.Pause

Resumes the selected service.Resume

Changes the startup mode of the selected service to automatic.Run automatically

Changes the startup mode of the selected service to manual.Run manually

Changes the startup mode of the selected service to disabled.Disable

Mass Storage node
This node contains mass storage items.

Table 5-12 Pages under the Mass Storage node

DescriptionPage

Displays disk drive information.Disk Drive

Displays floppy disk drive information.Floppy Disk Drive

Displays logical disk drive information.Logical Disk Drive

Displays CD/DVD device information.Media Device

Memory node
This node lets you view memory information.

Table 5-13 Pages under the Memory node

DescriptionPage

Displays cache memory information.Cache Memory

Displays logical memory configuration information.Logical Memory Configuration
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Table 5-13 Pages under the Memory node (continued)

DescriptionPage

Displays physical memory information.Physical Memory

Networking node
This node contains networking items.

Table 5-14 Pages under the Networking node

DescriptionPage

See “Filtering network traffic ” on page 32.Intel AMT Network
Filtering

This page is available only if Real-Time System Manager
detects that the target computer is configured to use Intel
AMT.

The page lets you change the network settings used by the
Intel AMT device on the managed computer. We recommend
that you configure the Intel AMT device to obtain an IP
address automatically to make sure the IP of the Intel AMT
device is always the same as the IP of the operating system.
The same IP lets you manage the computer using both WMI
and Intel AMT interfaces simultaneously.

Warning: Be careful when configuring the VLAN value. If the
value is incorrect, the Intel AMT devices will not be accessible.

Intel AMT Network
Settings

Displays information concerning the routing of network data
packets.

Internet packets are usually sent to a gateway and local
packets are routed directly by the client computer. You can
use this information to trace problems associated with
misrouted packets and direct a computer to a new gateway as
necessary. This class is only applicable to IP4 and does not
address IPX or IP6. The class is intended to provide the same
information that is shown when entering the route print
command at the command prompt.

IP4 Route Table

Displays network adapter information.Network Adapter

Displays network adapter configuration information.Network Adapter
Configuration
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Table 5-14 Pages under the Networking node (continued)

DescriptionPage

Displays network connection information.

Note: To view network connection information, the target
computer must have Microsoft .NET server installed or be
running Microsoft Windows XP.

Network Connections

Displays server connection information.Server Connections

Displays server session information. This item implements
the Win32_ServerSessions WMI class. It is available only on
Windows XP/2003 operating systems.

Server Sessions

Displays active wireless profile for provisioned notebook
computers with Intel AMT. Displays provisioning profiles
stored in the Intel AMT memory and their priority.

Wireless Profile (Intel
AMT)

Operating System node
This node contains operating system information.

Table 5-15 Pages under the Operating System node

DescriptionPage

Displays the local time settings.Local Time

Displays general operating system information.Operating System

Displays page file settings, such as initial and maximum size, and
location.

Page File Settings

Displays the printing jobs. The Total Pages value is the number
of pages required to complete the printing job.

Printing Jobs

Displays Internet connections related to Windows Product
Activation (WPA).

Proxy Server

Displays information on the target computer’s quick fixes. Quick
fixes are software updates and fixes, such as service pack updates
and hotfixes .

Quick-Fix Engineering

Displays registry information, such as size, install date, location,
and status. You can update the proposed size for the registry.

Registry

Displays the share information on the target computer.Share
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Table 5-15 Pages under the Operating System node (continued)

DescriptionPage

Displays terminal server settings.Terminal Server

Physical System node
This node contains firmware and hardware information.

Table 5-16 Pages under the Physical System node

DescriptionPage

Displays information about third-party management
agents that report their status to the Intel AMT device.

Agent Watchdogs

Displays BIOS information.BIOS

Displays hardware and firmware information.Computer System

Displays Field Replaceable Unit information.

Field Replaceable Unit (FRU) is a PCI or PCI Express bus
add-in hardware component of a computer that can be
replaced in the field, which takes no special devices (such
as a soldering iron) to install. If no or an unknown FRU
is detected, no description appears.

Field Replaceable Unit (Intel
AMT)

Displays motherboard device information.Motherboard Device

Displays processor information.Processor

Displays SMBIOS memory information.SMBIOS

Displays sound device information.Sound Device

Summary page
This page shows the target computer's summary information.

Note: Antivirus information is available only for computers with Inventory
Agent/Plug-in installed.

For more information, see the Inventory Solution User's Guide.
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Network Filters page
On this page, you can configure the list of ports to keep open when you enable
the Network Filtering feature of Intel AMT.

See “Filtering network traffic ” on page 32.

See “Filtering network traffic on multiple computers ” on page 38.

Warning:We recommend that you back up the default list of filters before making
any changes. The Export to file symbol lets you back up the default list.

See “About network filtering ports and settings” on page 63.

Table 5-17 Options on the Network Filters page

DescriptionOption

Clears the list of filters.Clear list

Loads the list of filters from the .xml file that Real-Time System Manager
uses as default.

Load

Saves the list of filters into the .xml file that Real-Time System Manager
uses as default.

Warning: Before saving, make sure you backed up the default .xml file.

Save

Imports the list of filters from an .xml file.Import from file

Saves the list of filters to an .xml file.

You can use the .xml file as a backup . You can also create a custom .xml
file to use with the Network Filtering task.

See “Filtering network traffic on multiple computers ” on page 38.

Export to file

Adds a filter.

Follow the steps in the wizard.

Add

Edits the filter that you selected in the list.

Follow the steps in the wizard.

Edit

Deletes the filter that you selected in the list.Delete
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Troubleshooting

This appendix includes the following topics:

■ Troubleshooting connection errors through the Real-Time view

Troubleshooting connection errors through the
Real-Time view

There are numerous reasons why Real-Time System Manager cannot establish a
connection with the target computer.

Table A-1 Possible reasons of connection errors

Possible reasonsTechnology

The connection credentials are incorrect.

The computer is turned off .

The operating system is not loaded.

The computer is not connected to the network.

The firewall does not allow incoming WMI connections.

See “Configuring the firewall to allow WMI connection” on page 55.

Simple file sharing is enabled.

See “Disabling simple file sharing on Windows XP SP2” on page 58.

User Access Control is turned on.

See “Configuring User Access Control on Windows Vista” on page 58.

You are connecting to Microsoft Windows XP Home Edition, where WMI
remote connection is not available.

You are connecting with a user that has an empty password.

WMI
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Table A-1 Possible reasons of connection errors (continued)

Possible reasonsTechnology

The connection credentials are incorrect.

ASF is turned on in the BIOS but not configured.

For more information on configuring computers with ASF, see the Out of
BandManagement Component Implementation Guide.

ASF is turned off in the BIOS.

The computer is not connected to the network.

The target computer is not ASF-capable.

ASF

The connection credentials are incorrect.

The Intel AMT device is not configured.

For more information on configuring computers with Intel AMT, see the
Out of BandManagement Component Implementation Guide.

The Intel AMT device is in secure mode, but the connection profile is not
configured to use the correct certificates.

For more information on configuring connection profiles, see the Symantec
Management Platform Help.

Intel AMT is turned off in the BIOS.

The computer is not connected to the network.

The computer is not Intel AMT-capable.

Intel AMT

The connection credentials are incorrect.

DASH is turned on in the BIOS but not configured.

For more information on configuring computers with DASH, see theOut of
BandManagement Component Implementation Guide.

DASH is turned off in the BIOS.

The computer is not connected to the network.

The target computer is not DASH-capable.

DASH

The SNMP community string is incorrect.

SNMP is not installed on the target computer.

The SNMP service is not running on the target computer.

The Notification Server computer is not in the list of hosts to accept the
SNMP packets from. Check SNMP service properties.

SNMP
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Configuring the firewall to allow WMI connection
The WMI credentials can be displayed as “Invalid” on the Real-Time Consoles
page when you try to perform one-to-one management of a computer with the
Microsoft Windows XP Service Pack 2 or Windows Vista operating system.

This issue can occur when the default configuration of the Windows Firewall
program in Windows XP SP2 and Vista blocks incoming network traffic for
Windows Management Instrumentation (WMI) connection. For the connection
to succeed, the remote computer must permit incoming network traffic on TCP
ports 135, 445, and additional dynamically-assigned ports, typically in the range
of 1024 to 1034.

You can resolve this issue in one of the following ways:

■ Configure the firewall on the computer you want to connect to.
See “Configuring the firewall on a single computer” on page 55.

■ Configure the firewall on all computers in the domain using group policy.
See “Configuring the firewall on multiple domain computers using group
policy” on page 56.

■ Temporarily disable the firewall.

Configuring the firewall on a single computer
For evaluation, you can configure the firewall using the computer’s local settings.

See “Configuring the firewall to allow WMI connection” on page 55.

To configure the firewall on Windows XP SP2

1 Log on to the target computer as the administrator.

2 Click Start > Run, type gpedit.msc in the Open dialog box, and then click
OK.

3 In the Group Policy window, click Local Computer Policy > Computer
Configuration > Administrative Templates > Network > Network
Connections > Windows Firewall.

4 If the computer is in a domain, click Domain Profile. If the computer is not
in a domain, click Standard Profile.

5 Double-click Windows Firewall: Allow remote administration exception,
click Enable, and then click OK.
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To configure the firewall on Windows Vista

1 Log on to the target computer as the administrator.

2 From the Control Panel, open the Windows Firewall Settings dialog box.

3 On the Exceptions tab, check WindowsManagementInstrumentation(WMI).

Configuring the firewall on multiple domain computers using
group policy
These steps assume that all the computers that you want to manage by using this
policy are in the same organizational unit.

For more information about how to use Group Policy, visit the following Microsoft
Web site:

http://technet.microsoft.com/en-us/windowsserver/grouppolicy/default.aspx

These steps assume that Windows Firewall is configured to use the domain profile.
The domain profile is the most typical scenario.

For more information about Windows Firewall profiles and about how Windows
selects the profile to load, see theDeployingWindowsFirewall Settings forMicrosoft
Windows XP with Service Pack 2 guide.

To obtain this guide, visit the following Microsoft Web site:

http://www.microsoft.com/downloads/details.aspx?FamilyID=
4454e0e1-61fa-447a-bdcd-499f73a637d1&DisplayLang=en

See “Configuring the firewall to allow WMI connection” on page 55.

To configure the firewall on multiple domain computers using group policy

1 Create a Group Policy object for the organizational unit that contains the
Windows XP SP2 computers that you want to manage:

■ Log on to a domain controller.

■ Click Start>Run, type dsa.msc in the Open dialog box, and then click OK.

■ Expand your domain, right-click the organizational unit that you want to
create the Group Policy in, and then click Properties.

■ On the Group Policy tab, click New.

■ Type a name for the Group Policy object, and then press Enter.

■ Click Close.

2 Log on to a domain-member computer that is running Windows XP SP2 with
a user account that is a member of one or more of the following security
groups:
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■ Domain Admins

■ Enterprise Admins

■ Group Policy Creator Owners

3 Click Start > Run, type mmc in the Open dialog box, and then click OK.

4 On the File menu, click Add/Remove Snap-in.

5 On the Standalone tab, click Add.

6 In the Add Standalone Snap-in dialog box, click GroupPolicy, and then click
Add.

7 In the Select Group Policy Object dialog box, click Browse.

8 Click the Group Policy object that you want to update with the new Windows
Firewall settings.

For example, click the organizational unit that contains the Windows XP SP2
computers, click OK, and then click the Group Policy object that you created
in step 1.

9 Click OK, and then click Finish.

10 Click Close, and then click OK.

11 Under the Console Root, expand the Group Policy object that you selected in
step 8, then click Computer Configuration > Administrative Templates >
Network > Network Connections > Windows Firewall > Domain Profile.

12 In the right pane, double-click Windows Firewall: Allow remote
administration exception.

13 Click Enabled, and then specify the administrative scope in the Allow
unsolicited incoming messages from dialog box.

For example, to permit remote administration from a particular IP address,
type that IP address in the Allow unsolicited incoming messages from dialog
box. To permit remote administration from a particular subnet, type that
subnet by using the Classless Internet Domain Routing (CIDR) format. In this
scenario, type 192.168.1.0/24 to specify the network 192.168.1.0 with a 24-bit
subnet mask of 255.255.255.0.

For more information on how to specify a valid administrative scope, see the
Syntax area of the Setting tab in this policy.

14 Click OK, and then click Exit on the File menu.
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Disabling simple file sharing on Windows XP SP2
This is a Windows XP limitation caused by the “ForceGuest” option that is enabled
by default on all Windows XP computers that are members of a workgroup (in
contrast to domain members). All users who are logging onto such computers
over the network are forced to use the Guest account.

See “Configuring the firewall to allow WMI connection” on page 55.

To disable simple file sharing

◆ Do one of the following steps:

■ Uncheck “Use simple file sharing” under the Control Panel > Folder
Options > View tab.

■ Set the “ForceGuest” DWORD value equal to 0 (zero) under the
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa] key
in the Windows registry on the client computer.
For more information, see Microsoft KB articles :
http://support.microsoft.com/default.aspx?scid=KB;EN-US;180548
http://support.microsoft.com/default.aspx?scid=kb;en-us;290403

Configuring User Access Control on Windows Vista
You can turn off the User Access Control (UAC) from the Control Panel. This
applies only to the computers that are not in a domain.

For more information, see Microsoft article http://technet.microsoft.com/en-us/
windowsvista/aa905108.aspx.

See “Configuring the firewall to allow WMI connection” on page 55.

To configure User Access Control

1 On the client computer with the Microsoft Windows Vista operating system,
open the Control Panel.

2 Double-click User Accounts.

3 In the User Accounts dialog box, click Turn User Account Control on or off.

4 Uncheck Use User Account Control (UAC) to help protect your computer,
and then click OK.

Troubleshooting
Troubleshooting connection errors through the Real-Time view

58

http://support.microsoft.com/default.aspx?scid=KB;EN-US;180548
http://support.microsoft.com/default.aspx?scid=kb;en-us;290403
http://technet.microsoft.com/en-us/windowsvista/aa905108.aspx
http://technet.microsoft.com/en-us/windowsvista/aa905108.aspx


Technical Reference

This appendix includes the following topics:

■ About the ports used by Real-Time System Manager

■ About authentication

■ About changes in default system security

■ About registry settings

■ Upgrading custom views

■ About network filtering ports and settings

■ Modifying the network filtering settings

■ About power management and redirection

About the ports used by Real-Time System Manager
The following table lists the ports that are used for communication by Real-Time
System Manager, Symantec Management Platform, and the Symantec Management
Console. You can use the table to configure the firewall between your console,
server, and managed computers as needed.

Table B-1 Ports used by Real-Time System Manager

BindingDirectionDescriptionPortProtocol

Symantec Management
Console -- Symantec
Management Platform

bothWWW (HTTP)80TCP
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Table B-1 Ports used by Real-Time System Manager (continued)

BindingDirectionDescriptionPortProtocol

Symantec Management
Console -- Symantec
Management Platform

bothLDAP389TCP

Symantec Management
Console -- Symantec
Management Platform

both(optional) SSL
(HTTPS)

443TCP/UDP

Symantec Management
Platform -- managed
computer

bothEcho (ICMP)7TCP/UDP

Symantec Management
Platform -- managed
computer

bothDCE endpoint
resolution

135TCP/UDP

Symantec Management
Platform -- managed
computer

bothMicrosoft-DS445TCP/UDP

Symantec Management
Platform -- managed
computer

bothRPC>1024TCP/UDP

Real-Time System
Manager -- managed
computer

bothSNMP161UDP

Real-Time System
Manager -- managed
computer

bothSNMP trap162UDP

Real-Time System
Manager -- managed
computer

bothNon-secure
Intel AMT
connection
port

16992TCP

Real-Time System
Manager -- managed
computer

bothSecure Intel
AMT
connection
port

16993TCP

Technical Reference
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Table B-1 Ports used by Real-Time System Manager (continued)

BindingDirectionDescriptionPortProtocol

Real-Time System
Manager -- managed
computer

bothNon-secure
Intel AMT
remote
control port
(SOL/IDE-R)

16994TCP

Real-Time System
Manager -- managed
computer

bothSecure Intel
AMT remote
control port
(SOL/IDE-R)

16995TCP

About authentication
Authentication happens on the Notification Server computer where Real-Time
System Manager is installed.

When you use Real-Time System Manager, the following authentication points
apply:

■ When you try to access the Symantec Management Console or the Resource
Manager page (either as a user who is interactively logged on to the Notification
Server computer or as a user connected to the Notification Server computer
remotely through a browser), Notification Server verifies that the user has the
rights to access Real-Time System Manager. In case of an interactively logged
on user, the Windows logon information is passed to Notification Server. When
a computer is managed locally from a target computer, the Internet Explorer
credentials are used.

■ By default, Real-Time System Manager uses the Notification Server Application
Identity credentials (WMI Credential for Default Connection Profile) to connect
to remote computers. If the Notification Server Application Identity account
has no administrator rights to access the remote computer, the connection
will fail. Create a new connection profile with correct credentials.

■ Once successfully authenticated, Real-Time System Manager
administrative-user credentials are used as “administrative” credentials for
all WMI commands until the Resource Manager page is closed.

■ If the Notification Server computer and the target computer are on different
domains, then in most cases you need to specify the user in the form of
"domain\username" and the password in the connection profile. This is not
true for the following cases:
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■ If there is a trust relationship between domains such that users from the
Notification Server domain have a sufficient privilege level (on the target
Real-Time System Manager host) that is required by WMI.

■ If the target computer has a local account (with sufficient WMI rights)
whose user name and password are identical to the user whose credentials
were used to access Real-Time System Manager.

About changes in default system security
During installation and setup of Real-Time System Manager, the access list for
the Windows_Folder\Temp directory is changed as follows:

■ The IIS_WPG (SERVER_NAME\IIS_WPG) group is added with full control for
the folder, subfolder, and files.

■ The ASP.NET computer account (SERVER_NAME\ASPNET) user is added with
full control for the folder, subfolder, and files.

About registry settings

Warning: Incorrectly editing the registry may severely damage your system. We
recommend backing up any valued data on the computer before making changes
to the registry.

The following table describes Windows registry values for Real-Time System
Manager.

The registry values location is
[HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\eXpress\Notification
Server\ProductInstallation\{13987439-8929-48d2-aa30-ef4bf0eb26a6}]

Table B-2 Real-Time System Manager registry values

DescriptionDefaultTypeValue

This timeout (in seconds) is
used by the Port Check tool.

3DWORDPingTimeout

This timeout (in seconds) is
used during WMI connection
to a target computer.

20 (dec)DWORDWMITimeout

Technical Reference
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Upgrading custom views
You can use the XslTransform utility to upgrade custom views for previous versions
of Real-Time System Manager (including Altiris Web Administrator for Windows
Solution). The utility can be found on the computer where Real-Time System
Manager was installed, in the
%ProgramFiles%\Altiris\RTSM\Tools\ViewTransform folder.

The syntax of the command is:

XslTransform <input.xml> <transform.xslt> [output xml]

Note:All known solutions’ custom views for previous versions of Real-Time System
Manager should be migrated automatically without any user intervention. For
example, the views for Altiris™ Fujitsu Siemens Computers DeskView and Altiris™
Recovery Solution.

Note:The sample SNMP custom view plug-in is installed by default with Real-Time
System Manager.

About network filtering ports and settings
To allow communication with the Notification Server computer for remediation,
the following ports stay open on the target computer when network filtering is
active.

Table B-3 Ports kept open when network filtering is active

DirectionTypePort name and
description

Port #

Receive/TransmitTCP/UDPDNS port53

Receive/TransmitUDPDHCP boot protocol
server

67

Receive/TransmitUDPDHCP boot protocol client68

Receive/TransmitTCPNotification Server port80*

Receive/TransmitUDPKerberos port88

Receive/TransmitTCPNETBIOS Name Service137

Receive/TransmitTCP/UDPLDAP port389
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Table B-3 Ports kept open when network filtering is active (continued)

DirectionTypePort name and
description

Port #

Receive/TransmitTCP/UDPSecure LDAP port636

Receive/TransmitEthernet frameARP2054

Receive/TransmitTCPNotification Server Tickle
port

52028*

* Depends on the Notification Server configuration

See “Modifying the network filtering settings” on page 64.

See “Filtering network traffic on multiple computers ” on page 38.

Modifying the network filtering settings
You can modify the list of ports to keep open when network filtering is active on
the Network Filters page.

See “About network filtering ports and settings” on page 63.

See “Filtering network traffic on multiple computers ” on page 38.

To modify the network filtering settings

1 In the Symantec Management Console, on the Settings menu, click All
Settings.

2 In the left pane, click Remote Management > Real-Time System Manager >
Network Filters.

3 Modify the filters.

About power management and redirection
The following table displays the power management and redirection capabilities
for the Intel AMT or ASF-capable computers in different power states.

Table B-4 Intel AMT power management capabilities

Boot
redirect3

AMT power
on

AMT power
off

AMT rebootPower state

Yes2NoYesYesS0/G0 “working”
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Table B-4 Intel AMT power management capabilities (continued)

Boot
redirect3

AMT power
on

AMT power
off

AMT rebootPower state

YesNoYesYesS1 “sleeping with system
h/w & processor context
maintained”

YesNoNoNoS2 “sleeping, processor
context lost”

Yes2YesYes1Yes1S3 “sleeping, processor &
h/w context lost, memory
retained”

Yes2YesYes1Yes1S4 “non-volatile sleep /
suspend-to disk”

YesYesNoNoS5/G2 “soft-off”

YesNoNoNoS4/S5 soft-off, particular
S4/S5 state cannot be
determined

NoNoNoNoG3/Mechanical Off

YesNoNoNoSleeping in an S1, S2, or S3
states (used when particular
S1,S2, S3 state cannot be
determined), or Legacy
SLEEP state

YesNoNoNoG1 sleeping (S1-S4 cannot
be determined)

YesNoNoNoS5 entered by override (For
example, by 4-second power
button override)

YesNoNoNoLegacy ON (For example,
non-ACPI OS working state)

YesNoNoNoLegacy OFF (For example,
non-ACPI OS off state)

YesNoNoNoUnknown

1 Performed through the power on command.

2 Redirection can be enabled only for the reboot command.
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Table B-5 ASF power management capabilities

Boot redirect3ASF power
on

ASF power
off

ASF rebootPower state

Yes2NoYesYesS0/G0 “working”

YesNoYesYesS1 “sleeping with system
h/w & processor context
maintained”

YesNoYesYesS2 “sleeping, processor
context lost”

Yes2YesYesYesS3 “sleeping, processor &
h/w context lost, memory
retained”

Yes2YesYes1Yes1S4 “non-volatile sleep /
suspend-to disk”

YesYesNoNoS5/G2 “soft-off”

YesYesYesYesS4/S5 soft-off, particular
S4/S5 state cannot be
determined

NoNoNoNoG3/Mechanical Off

YesNoYesYesSleeping in an S1, S2, or
S3 states (used when
particular S1,S2, S3 state
cannot be determined),
or Legacy SLEEP state

YesNoYesYesG1 sleeping (S1-S4
cannot be determined)

YesYesNoNoS5 entered by override
(For example, 4-second
power button override)

YesNoYesYesLegacy ON (For example,
non-ACPI OS working
state)

YesYesNoNoLegacy OFF (For example,
non-ACPI OS off state)

YesYesYesYesUnknown
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1 Performed through the power up command.

2 Redirection can be enabled only for the reboot command.

3 Only local redirection can be enabled with ASF.
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Altiris Agent The software that is installed on the computers that you want to manage. It
facilitates interactions between Notification Server and a managed computer.
The agent receives requests for information from Notification Server, sends data
to Notification Server, and downloads files. The Altiris Agent also lets you install
and manage solution plug-ins that add functionality to the agent.

ASF (Alert Standard

Format)

An industry standard-based technology that lets IT administrators manage
computers regardless of the operating system state. ASF provides alerts and power
management functionality as long as the computer is plugged in with an Ethernet
connection. ASF functions through hardware on the network card or system board,
a software agent on the client computer, and management software on the server.

Circuit Breaker A security toolset of Intel AMT. This toolset represents a set of hardware-based
network packet filters. IT technicians can apply these filters to computers that
send suspicious network packets to seal infected computers from the rest of the
network.

DNS (Domain Name

System)

A system that converts host names and domain names into IP addresses on the
Internet or on the local networks that use the TCP/IP protocol. For example, when
a Web site address is given to DNS, DNS servers return the IP address of the server
that is associated with that name.

IDE-R (IDE-Redirection) An Intel AMT built-in hardware capability. It lets IT administrators start a
computer from an image that is stored on the network or on the remotely mounted
CD-ROM or hard drive.

in-band management A type of remote computer management. It requires the target computer's
operating system to be initialized and to function properly.

Intel AMT (Intel Active

Management

Technology)

A solution that is based in hardware and firmware and is connected to the system's
auxiliary power plane. Despite the power state or the operating system state of
the client computer, Intel AMT provides IT administrators with access to alerts,
hardware inventory, power management, circuit breaker, and agent presence
functionality. Intel AMT functionality requires the computer to be plugged into
the power source and connected to the network. Intel AMT functionality does not
require a software agent to be installed on the client computer.

Notification Server The Symantec Management Platform service that communicates with the Altiris
Agent and the CMDB to provide management, security, and administrative
functionality. It processes events, facilitates communications with managed
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computers, and coordinates the work of the other Symantec Management Platform
services.

out-of-band

management

A type of remote computer management. It lets IT administrators connect to a
computer's management controller when the computer is turned off, in sleep or
hibernate modes, or otherwise unresponsive through the operating system.
Out-of-band management can be performed on the computers that have Intel
AMT, DASH, or ASF-capable network adapters.

PET (Platform Event

Trap)

An event that is originated directly from platform firmware (BIOS) or platform
hardware (ASIC, chipset , or microcontroller) independently of the state of the
operating system or system management hardware. PET events provide advance
warning of possible system failures.

power state The overall power consumption of the system. Six power states exist that range
from S0 (the system is powered on and fully operational) to S5 (the system is
powered off). States S1, S2, S3, and S4 are referred to as sleeping states.

PXE Boot (Pre-Boot

ExecutionEnvironment)

An environment to start computers using a network interface independently of
available data storage devices (like hard disks) or installed operating systems. An
administrator can load operating systems and other software onto the device
from a server over the network.

Resource Manager A feature that displays information about a resource, such as its properties and
current state. It also lets you troubleshoot and perform actions on managed
resources.

SOL (Serial-over-LAN) A feature of Intel AMT that redirects console output to a remote terminal. It lets
IT administrators remotely change BIOS settings, repair a computer that cannot
start, and so on.

SOL/IDE-R (Serial-over-

LAN/IDE-Redirection)

The proprietary protocols that are defined for Intel AMT that redirect keyboard,
text, floppy disk, and CD transfers from a local host to a remote workstation.

Symantec Management

Console

The Web-based user interface for managing the Symantec Management Platform
and any other installed solutions.

Symantec Management

Platform

The platform that provides a set of services for IT-related solutions. These services
include security, scheduling, client communications and management, task
execution, file deployment, reporting, centralized management, and CMDB
services.

task An action that is performed on a computer. Server tasks are run on Notification
Server. Client tasks are run on managed computers.

task server A managed computer on which the Task Service plug-in is installed. The task
server lets you sequence tasks and provides automation for Symantec solutions.
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